Problemer med localhost opsætning?

Få hjælp og support til alt server-relateret. Guides og How-to's i forbindelse med servere hører også til her.
Rattus Norvegicus
Indlæg: 511
Tilmeldt: 9. maj 2009, 07:14
Geografisk sted: Albertslund

Problemer med localhost opsætning?

Indlæg af Rattus Norvegicus »

Jeg har muligvis et problem med min apache-opsætning, som jeg håber der sidder en herinde der kan hjælpe mig med.

Jeg har installeret Joomla på min localhost og dertil har jeg installeret et galleri-modul der hedder JoomGallery, og når jeg oploader billeder fra administrationsdelen i Joomla er der ingen problemer, her oploades, behandles i GD2 (ændrer størrelsen og laver thumbnails), samt indsættes data i databasen på max 2 sekunder pr. billede.

I frontend tager samme præcis process ca. 2 minuter pr. billede.

Umiddelbart troede jeg problemet lå hos modulet JoomGallery, men efter at have kopieret min Joomla-installation og databasen til et webhotel er der ingen problemer med billedeupload fra frontend, og derfor tænker jeg nu at det kan skyldes en fejl i min serveropsætning?

Og for at gøre det endnu mere forvirrende og mystisk:
Hvis jeg bruger Joomla's egen indbyggede upload-funktion (som desværre ikke har alle de funktioner jeg har brug for) er der heller ikke problemer med hastigheden.

Nogen der har en idé om hvad der kan være galt, for nu har jeg kæmpet med dette og søgt på Google i 4 lange dage uden at finde noget der bare minder om en løsning?
Hilsen Kenny
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Problemer med localhost opsætning?

Indlæg af AJenbo »

Skal den på nogen måde skabe forbindelse ud af til?
Rattus Norvegicus
Indlæg: 511
Tilmeldt: 9. maj 2009, 07:14
Geografisk sted: Albertslund

Re: Problemer med localhost opsætning?

Indlæg af Rattus Norvegicus »

Ikke så vidt jeg kan se.
Hilsen Kenny
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: Problemer med localhost opsætning?

Indlæg af lath »

Rattus Norvegicus skrev:Jeg har muligvis et problem med min apache-opsætning, som jeg håber der sidder en herinde der kan hjælpe mig med.

Jeg har installeret Joomla på min localhost og dertil har jeg installeret et galleri-modul der hedder JoomGallery, og når jeg oploader billeder fra administrationsdelen i Joomla er der ingen problemer, her oploades, behandles i GD2 (ændrer størrelsen og laver thumbnails), samt indsættes data i databasen på max 2 sekunder pr. billede.

I frontend tager samme præcis process ca. 2 minuter pr. billede.

Umiddelbart troede jeg problemet lå hos modulet JoomGallery, men efter at have kopieret min Joomla-installation og databasen til et webhotel er der ingen problemer med billedeupload fra frontend, og derfor tænker jeg nu at det kan skyldes en fejl i min serveropsætning?

Og for at gøre det endnu mere forvirrende og mystisk:
Hvis jeg bruger Joomla's egen indbyggede upload-funktion (som desværre ikke har alle de funktioner jeg har brug for) er der heller ikke problemer med hastigheden.

Nogen der har en idé om hvad der kan være galt, for nu har jeg kæmpet med dette og søgt på Google i 4 lange dage uden at finde noget der bare minder om en løsning?

strace og ltrace
Det er nogle af de mere avancerede kommandoer du kan bruge, hvis du ikke har lyst til at spilde din tid til at gætte i øst og vest.

De kan fortælle dig hvad et program/flere programmer gør.
strace og ltrace til at spore henholdsvis sysemkald til kernen, og kald til softwarebiblioteker for en bestemt process.

strace og ltrace skal bruget et såkaldt PID, proces id.
Ethvert program kører med et bestemt PID, som er tildelt af kernen.
Det tal kan findes med pgrep, feks.:)

Kode: Vælg alt

pgrep apache

... skriver PID numrene for alle apache programmer
PHP kører i en seperat process som du også skal køre strace og ltrace på., så du skal også have fat i dens PID.

Manual siderne til de programmer er her
Begge kommando har et -p argumentet, som bruges til at angive et programs PID.

Start med at bruge strace, da det er nemmere at finde ud af hvad et program har gang i ved at trace systemkald end det er at trace softwarebibliotekskald. Softwarebibliotekskald resulterer i en del tilfælde i at et systemkald bliver udført.

Det du så er på udkig efter er steder, hvor softwaren bruger unødigt lang tid.
  • Er det i Apache web serveren, ja så skal du nærstudere - og ændre i - dens konfigurationsfil.
  • Er det PHP fortolkeren som bruger lang tid, så er det muligvis en Joomla indstilling, da den laver frontend.
  • Er det GD2, laves der måske nogle unødigt meget tunge beregninger på billederne, og det må så være en indstilling i JoomGallery og/eller en indstilling for GD2,som du skal ind og pille i.

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags