JabRef version 3 og version 4; installation??? Emnet er løst

Søger du et bestemt program? Mangler du et alternativ til dit Windowsprogram? Program-spørgsmål kan stilles her.
xpas2r
Indlæg: 38
Tilmeldt: 10. dec 2013, 11:36
IRC nickname: xpas2r

JabRef version 3 og version 4; installation???

Indlægaf xpas2r » 23. sep 2018, 22:05

Hi,
Jeg har i Ubuntu installeret JabRef; Ubuntus version er en version 3.8.2. (Ubuntu 18.04)
For at integrere JabRef med Firefox skal man bruge JabFox add-ons for Firefox, som imidlertid forudsætter mindst JabRef version 4.2.
Hvordan opgraderer man JabRef fra version 3.8.2 til version JabRef 4.2. i Ubuntu?
xpas2r

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: JabRef version 3 og version 4; installation???

Indlægaf AJenbo » 23. sep 2018, 22:41


xpas2r
Indlæg: 38
Tilmeldt: 10. dec 2013, 11:36
IRC nickname: xpas2r

Re: JabRef version 3 og version 4; installation???

Indlægaf xpas2r » 24. sep 2018, 12:39

Tak for link!

Meen som jeg læser link og kontekst, vedrører denne ppa kun installationen af Java, og dén skulle på forhånd være ok; programmet JabRef skulle kunne køre på java 8, og som jeg læser promptsvar på versionsspørgsmål i terminalvindue, er det dén, der kører på maskinen. (Ubuntu 18.04)
---------
...da jeg igen, igen forsøgte at bruge java-kommandoen på den downloadede programfil (JabRef-4.3.1.jar), fik jeg igen, igen en advarsel om, at filen ikke var excutable; dét ændrede jeg med 'sudo chmod ...'
...det virkede stadig ikke! ... Så nyinstallerede jeg java-programmet med det opgivne link:

Install Oracle JDK with “personal packages archiv (ppa)” which includes an automated update function:
Add repository: sudo add-apt-repository ppa:webupd8team/java
Update package list: sudo apt-get update
Install: sudo apt-get install oracle-java8-installer

Derefter brugte jeg java-kommandoen på programmets jar-fil:
java -jar /home/xpas2r/Hentet/JabRef/JabRef-4.3.1.jar

....OG mirabile visu: programmet åbnede og kan køre som java-program; men...
...NU kan jeg kun åbne JabRef ved at bruge java-kommandoen, og Firefox kan ikke 'se' / 'finde' den installerede JabRef-version.

Hvordan får jeg sat en app-knap op i min launchsøjle (venstre side)?
Hvordan får jeg Ubuntu / linux til at registrere, at java-kommandoen skal / kan køre programmet?

Tilbage til "Programmer i Ubuntu"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster