netbank og nemid, dr.dk osv osv Emnet er løst

Søger du et bestemt program? Mangler du et alternativ til dit Windowsprogram? Program-spørgsmål kan stilles her.
Jørgen L Sørensen
Indlæg: 54
Tilmeldt: 24. aug 2009, 19:02
Geografisk sted: Sønderborg

Re: netbank og nemid, dr.dk osv osv

Indlægaf Jørgen L Sørensen » 7. feb 2012, 10:24

Stra skrev:Det er ikke Mozilla der er den direkte årsag til problemet, men supporterne på NemID der ikke kan følge med og få lavet den patch der skal, til for at det virker med Firefox 10.
support NemId


Kan du uddybe hvad der er problemet? Min umiddelbare tanke er at det er Firefox 10 der har et problem - men jeg kender ikke så meget til det og kan selvfølgelig ikke udelukke at det er NemID boks der har en gammel fejl som først viser sig nu.

Jeg har ikke umiddelbart kunnet finde noget på nettet om årsagen til problemet.

Har lige kigget på dit link - og det undrer mig at NemID kun understøtter til Firefox 7 når de plejer at slå på at vi skal holde vore systemer opdateret!
mvh
Jørgen Linde Sørensen

Brugeravatar
NickyThomassen
Admin
Indlæg: 3643
Tilmeldt: 5. mar 2010, 19:58
IRC nickname: nicky
Geografisk sted: 192.168.20.42

Re: netbank og nemid, dr.dk osv osv

Indlægaf NickyThomassen » 7. feb 2012, 10:45

Jørgen L Sørensen skrev:Har lige kigget på dit link - og det undrer mig at NemID kun understøtter til Firefox 7 når de plejer at slå på at vi skal holde vore systemer opdateret!

Vi er helt enige i at NemID til enhver tid burde understøtte current, altså den nuværende stabile, Firefox. Men med tanke på at Firefox i april sidste år var i version 3.5, og nu er i version 10, så er det måske ikke så underligt at de har svært ved at følge med.

Mozilla syntes jo åbenbart at Firefox' versionsnummer er meget vigtigt, så for at nå Chrome (version 16) og Internet Explore (version 9), har de udgivet hver minor realese som en selvstændig version. Det er ikke kun i den her sammenhæng det har givet problemer, nogle plugins har fx også været ramt af den hurtige stigning i versionsnumrene.

Jønse

Re: netbank og nemid, dr.dk osv osv

Indlægaf Jønse » 7. feb 2012, 10:53

Ja, det er noget ged :( Måske skal man overgå helt til Chromium, den er der sjældent problemer med 8-)

Blfriis
Indlæg: 445
Tilmeldt: 3. nov 2009, 10:50
IRC nickname: blfriis
Geografisk sted: Randers

Re: netbank og nemid, dr.dk osv osv

Indlægaf Blfriis » 7. feb 2012, 11:15

Midori virker til netbank så indtil de andre virker igen kan det måske være en midlertidig løsning.
Ubuntu 15.04 Unity og ZorinOS 9 Ultimate http://zorin-os.dk/index.php

Jørgen L Sørensen
Indlæg: 54
Tilmeldt: 24. aug 2009, 19:02
Geografisk sted: Sønderborg

Re: netbank og nemid, dr.dk osv osv

Indlægaf Jørgen L Sørensen » 7. feb 2012, 12:44

TitanusEramius skrev:Mozilla syntes jo åbenbart at Firefox' versionsnummer er meget vigtigt, så for at nå Chrome (version 16) og Internet Explore (version 9), har de udgivet hver minor realese som en selvstændig version. Det er ikke kun i den her sammenhæng det har givet problemer, nogle plugins har fx også været ramt af den hurtige stigning i versionsnumrene.


jeg er ikke inde i hvad der bliver ændret i versionerne, men nye versioner burde efter min mening ikke give problemer hvis "folk" gør deres arbejde godt nok og overholder spillereglerne.

Sagt på en anden måde:

Hvis browseren (og plug-in) overholder standarderne, og NemID overholder (samme) standarder burde en ny version (browser eller NemID-applet) ikke give problemer, heller ikke hvis der kommer nye funktioner. Jeg vil mene at problemerne opstår hvis en/begge parter undlader at overholde standarderne, enten bevidst eller på grund af en bug i produktet. Eller en gammel uopdaget bug pludselig bliver synlig på grund af en ændring i produktet.

Når nye versioner kommer som skidt fra en spædkalv kan man godt frygte at testfasen bliver afkortet for meget og der smutter lidt flere fejl med ud. Dermed ikke sagt at jeg ubetinget giver Firefox skylden for dette problem da jeg ikke ved hvori problemet opstår - men kun har mærket virkningen.

Under alle omstændigheder synes jeg det er en træls situation når en stor browser og en ret vigtig ting som NemID ikke kan arbejde sammen. Måske skulle man droppe dem begge to :cry:
mvh
Jørgen Linde Sørensen

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: netbank og nemid, dr.dk osv osv

Indlægaf Stra » 7. feb 2012, 12:53

stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: netbank og nemid, dr.dk osv osv

Indlægaf Stra » 7. feb 2012, 13:22

Okay, jeg æder min ord i mig igen. Firefox 10 virker på windows medn oracle java.

Mon problemet er, at os der ikke kan få det til at virke bruge openjava6.

Jeg har ikke lige haft tid at afprøve det med Oracle java
stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

Jørgen L Sørensen
Indlæg: 54
Tilmeldt: 24. aug 2009, 19:02
Geografisk sted: Sønderborg

Re: netbank og nemid, dr.dk osv osv

Indlægaf Jørgen L Sørensen » 7. feb 2012, 15:00

Stra skrev:En lille artikel der illustrere, hvad der kan være problemet.

http://www.version2.dk/artikel/skats-tastselv-erhverv-flopper-i-alt-andet-end-internet-explorer-43103


Ja, det ville være rart om man kunne blive enige om nogle standarder og så følge dem ......

NemID skriver følgende til mig i dag da jeg spurgte dem hvorfor de kun understøtter Firefox 7 når deres betingelser siger man skal holde sit system opdateret:

Tak for din henvendelse.
Af hensyn til de resourser der er til rådighed i udviklingsafdelingen har man valgt. at prioritere udviklingen af NemID erhverv frem for understøttelse af de sidste nye produkter fra mozilla.
Se evt. denne artikel, da den beskriver et lignende problem:
http://www.version2.dk/artikel/nemid-mac-os-x-linux-sikker-mail-kryptering-brugerbetingelser-42996


Det er stadig min mening at en eller anden har "glemt" at følge nogle standarder - eller også er der ingen standarder på lige netop dette område.
mvh
Jørgen Linde Sørensen

Buzzng84
Indlæg: 12
Tilmeldt: 17. jan 2012, 19:29

Re: netbank og nemid, dr.dk osv osv

Indlægaf Buzzng84 » 7. feb 2012, 15:36

Stra skrev:
laoshi skrev:Så vidt jeg kan se, er det nok at gå tilbage til FF 9 - det virkede i hvert fald for mig indtil opdateringen til FF 10
Det er korrekt at Firefox 9 kan anvendes. Når jeg skriver Firefox 7, er det fordi det var det valg jeg havde, med den metode jeg anvendte via synaptic. ellers skulle jeg ud at finde Firefox 9 og installere den manuelt.

Og version 7 er også kun ca. 20 uger gammel, så mon ikke den kan klare opgaverne :D


Men findes der ikke en nem måde at gå tilbage til version 9 på. Det er ikke fordi jeg er versions fikseret som sådan, og 20 uger er bestemt ikke lang tid. Men jeg er kun lige begyndt på ubuntu til fordel for Windows. Og mine erfaringer fra Windows siger mig at firefox opdateringer som oftest har noget med sikkerhedsbrister at gøre. Og det er måske nok så interessant at få dem ryttet af vejen når nu vi netop snakker om brug af blandt andet Netbank.
Med venlig hilsen
Ronni (buzzng84)

AJenbo
Admin
Indlæg: 20621
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: netbank og nemid, dr.dk osv osv

Indlægaf AJenbo » 9. feb 2012, 03:29

Det er klart en eller anden mystisk kombination der udløser problemet:
Firefox 9 + OpenJDK + NemID = Virker
Firefox 10 + Sun Java + NemID = Virker
Firefox 10 + OpenJDK + java.com test = Virker
Firefox 10 + OpenJDK + NemID = Crash

Buzzng84 skrev:Men findes der ikke en nem måde at gå tilbage til version 9 på.

Installer synaptic find Firefox pakken og tving versionen til 9.

naucher
Indlæg: 302
Tilmeldt: 23. jan 2009, 21:14
IRC nickname: naucher
Geografisk sted: Aabenraa

Re: netbank og nemid, dr.dk osv osv

Indlægaf naucher » 9. feb 2012, 18:14

AJenbo skrev:Installer synaptic find Firefox pakken og tving versionen til 9.

Tillad mig et lettere enfoldigt spørgsmål:
Hvordan gør man det :?:

- altså hvordan tvinger man Synaptec til at installere (downgrade til) version 9 :?:
(Synaptec har jeg (vi) jo allerede, for det er jo en del af Ubuntu-standard-pakken)

I min Synaptec står der bare, at installeret version er 10.0+build1 og dette står også i kolonnen "Seneste version"
De bedste hilsner
Naucher

Begejstret Bruger
Lenovo Thinkpad S540 (årg. 2014) | 8,0 GB RAM | 400 GB disk || Ubuntu 20.04LTS

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: netbank og nemid, dr.dk osv osv

Indlægaf Stra » 9. feb 2012, 19:11

naucher skrev:
AJenbo skrev:Installer synaptic find Firefox pakken og tving versionen til 9.

Tillad mig et lettere enfoldigt spørgsmål:
Hvordan gør man det :?:

- altså hvordan tvinger man Synaptec til at installere (downgrade til) version 9 :?:
(Synaptec har jeg (vi) jo allerede, for det er jo en del af Ubuntu-standard-pakken)

I min Synaptec står der bare, at installeret version er 10.0+build1 og dette står også i kolonnen "Seneste version"
marker linien Firefox 10 og åbn pakke/tving version og vælg.

Opdater, hvorved Firefox nedgraderes.

Derefter låses versionen via pakke/låsversion.

Du skal gøre det samme for firefox-locale-da og firefox-gnome-support, for at få dansk sprog og gnome-support
Senest rettet af Stra 11. feb 2012, 20:36, rettet i alt 2 gange.
stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

naucher
Indlæg: 302
Tilmeldt: 23. jan 2009, 21:14
IRC nickname: naucher
Geografisk sted: Aabenraa

Re: netbank og nemid, dr.dk osv osv

Indlægaf naucher » 11. feb 2012, 19:51

Stra skrev:marker linien Firefox 10 og åbn pakke/tving version og vælg.

Øhh - jo - men ...
Når jeg gør dette får jeg 2 valgmuligheder:
  • 10.0+build1-0ubuntu0.11.04.1 (natty-updates)
  • 4.0+nobinonly-0ubuntu3 (natty)
Hvilken en af dem, skal jeg vælge?
Eller det bedst at blive ved 10'eren?
De bedste hilsner
Naucher

Begejstret Bruger
Lenovo Thinkpad S540 (årg. 2014) | 8,0 GB RAM | 400 GB disk || Ubuntu 20.04LTS

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: netbank og nemid, dr.dk osv osv

Indlægaf Stra » 11. feb 2012, 20:33

10-eren virker ikke med openjava og NemID. Så for din maskine hedder det 4.0.

Ellers kan du installere Oraclejava og beholde firefox 10 se hvordan her http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

Buzzng84
Indlæg: 12
Tilmeldt: 17. jan 2012, 19:29

Re: netbank og nemid, dr.dk osv osv

Indlægaf Buzzng84 » 13. feb 2012, 22:02

Stra skrev:10-eren virker ikke med openjava og NemID. Så for din maskine hedder det 4.0.

Ellers kan du installere Oraclejava og beholde firefox 10 se hvordan her http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html


Når jeg kører den guide du nævner installerer den en hel masse. Og melder alt okay når den er færdig. Men når jeg gå ind på netbank er muligheden "Netbank" slet ikke at finde i logon menuen. Hvilket plejer at betyde at man ikke har den java der kræves.

Ska man gøre noget udover guiden for at få det til at virke. Når jeg copy/paster den tredje kommando i guiden beder den om min administrator kode, men der sker ikke noget ved enter. Nogen ideer?
Med venlig hilsen
Ronni (buzzng84)

Tilbage til "Programmer i Ubuntu"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster