Kan ikke starte program Emnet er løst

Alle tekniske spørgsmål som ikke hører ind under de andre fora.
karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Kan ikke starte program

Indlægaf karl » 17. sep 2015, 16:15

Hej forum
Min pc løb tør for plads, da jeg lagde en masse billeder ind. Det fik mit fotoprogram Aftershot til at crashe.
Jeg kan ikke starte det igen. Jeg har forsøgt at afinstallere det vha Softwarecenter og installere igen. Der sker stadig intet, når jeg klikker på ikonet.
Installation gik uden problemeer, så der må hænge et eller andet, som blokerer.
Jeg har lavet mere plads på harddisken, så det skulle være ok.
Vh
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke starte program

Indlægaf AJenbo » 17. sep 2015, 21:23

Kode: Vælg alt

df -h


Hvad skrive den ved den kommando?

karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Kan ikke starte program

Indlægaf karl » 17. sep 2015, 21:45

Hej
Den skriver
Filsystem Størr Brugt Tilb Brug% Monteret på
/dev/sda1 114G 45G 63G 42% /
none 4,0K 0 4,0K 0% /sys/fs/cgroup
udev 3,9G 4,0K 3,9G 1% /dev
tmpfs 786M 1,6M 785M 1% /run
none 5,0M 0 5,0M 0% /run/lock
none 3,9G 84K 3,9G 1% /run/shm
none 100M 36K 100M 1% /run/user
/dev/sdb1 466G 342G 125G 74% /media/karl/Expansion Drive
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Kan ikke starte program

Indlægaf karl » 18. sep 2015, 18:35

Hej
Er der en kommando, som mere effektivt kan fjerne blokeringen, som måske er årsagen til, at jeg ikke kan starte programmet?
Eller skal jeg forsøge at fjerne alle filer manuelt?
Hilsen
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke starte program

Indlægaf AJenbo » 18. sep 2015, 21:35

Prøv at tjekke om det er dine personlige indstillinger ved at starte programmet fra en gæste session. Personlige bruger indstillinger fjernes ikke når programmet afinstalleres

karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Kan ikke starte program

Indlægaf karl » 18. sep 2015, 21:38

Det fungerede. I gæstesessionen startede det op, som det skulle.
Hvad gør jeg så?
Vh
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Kan ikke starte program

Indlægaf Blueeyez » 18. sep 2015, 21:39

Har du prøvet at genstarte pcen når programmet er fjernet?
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Kan ikke starte program

Indlægaf karl » 18. sep 2015, 21:48

Ja, det er forsøgt.
Kan man fjerne indstillingerne manuelt?
Vh
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Kan ikke starte program

Indlægaf zob » 18. sep 2015, 23:10

Ja, det kan du godt. (Grunden til at flere, inkl. undertegnede, tøver med at hjælpe, er sikkert at man ikke bare lige kan installere programmet fra repos og teste selv).

Følgende skal gøres når du er logget ind som den bruger der har problemer - ikke gæstebruger.

Hvis følgende stadig gælder, er dine settings i en skjult mappe under din hjemmemappe. Hvilket betyder at du også kan se din settings folder ved at åbne nautilus (stifinder) og taste CTRL+H for at vise skjulte filer (skjulte filer/mapper begynder med en punktum).
http://product.corel.com/help/AfterShot/540111115/Main/EN/Doc/index.html?file_locations.html

Hvis du kan se mappen som måske hedder .Corel AfterShot Pro kan du (sørg for at Aftershot er lukket) klippe (CTRL+X) mappen og paste (CTRL + V) den et andet sted, f.eks. i Dokumenter e.l. Det må du selv om. Det er bare fordi vi lige venter med at slette den helt. Det er dog vigtigt at du sikrer dig at der ikke længere er en .Corel AfterShot Pro mappe i din hjemmemappe.

Når du efterfølgende starter Aftershot, har du ikke længere settings filer for din bruger og der vil blive genereret nye. Hvis det er settings-filerne der er problemet, vil det derfor være løst.

Hvis du ikke kan finde mappen, eller på anden vis er i tvivl så start med at give output af følgende:

Kode: Vælg alt

ls -ld ~/.C*

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke starte program

Indlægaf AJenbo » 18. sep 2015, 23:59

Frem for at flytte mappen forslår jeg at du omdøber den til "old.Corel AfterShot Pro" på den måde er den ikke skjult og bliver ikke væk et eller andet sted, og du skal ikke besluttet hvor du vil lægge den.

karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Kan ikke starte program

Indlægaf karl » 19. sep 2015, 09:09

Det hjalp desværre ikke.
Output fra kommandoen gav ikke noget:
ls: kan ikke tilgå /home/karl/.C*: Ingen sådan fil eller filkatalog

Jeg har flyttet alle mapper i hjemmemappen, der hedder noget med "Aftershot", så nu ved jeg ikke lige, hvad der kan forsøges!!
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Kan ikke starte program

Indlægaf zob » 19. sep 2015, 10:21

Nå. Jeg fandt en trial-version af programmet og fik installeret. Jeg kan se at de oplysninger vi gik ud fra ikke længere er korrekte. Så mappen med dine settings hedder ~/.AfterShot. Du skal derfor (sørg for at lukke AfterShot mens du udfører følgende), slette, omdøbe eller flytte denne mappe. Hvis vi vælger omdøbe kan du køre:

Kode: Vælg alt

mv ~/.AfterShot ~/.AfterShot.backup


Herefter kan du prøve at starte programmet igen. Gerne fra terminalen så vi kan se i outputtet hvad der går galt.

Kode: Vælg alt

AfterShot2X64
Og så smid det der skrives i terminalen herind. Sæt det helst i Code-tags.

Hvis kommandoen AfterShot2X64 ikke findes og dermed ikke starter noget som helst kan det være du har 32 bit versionen. Jeg ved ikke hvad den hedder, et bud kunne være AfterShot2, men du kan altid begynde at skrive AfterS i terminalen og taste TAB for at auto-complete.

EDIT: Ups. Jeg kan godt se du selv havde luret at den ikke nødvendigvis hed Corel AfterShot...., så du har sikkert flyttet eller omdøbt den mappe jeg taler om her. Hvis du gør det skulle det første der sker når du starter AfterShot være at spørge hvor du vil have din settings-mappe og din mappe med billeder. Gør den det? Men start, som sagt, programmet fra terminalen os vis os hvad den skriver.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke starte program

Indlægaf AJenbo » 19. sep 2015, 14:31

Kode: Vælg alt

find ~ -name *AfterShot*

karl
Indlæg: 679
Tilmeldt: 5. feb 2008, 19:08
Geografisk sted: Ryslinge, Fyn

Re: Kan ikke starte program

Indlægaf karl » 19. sep 2015, 15:40

Der er ikke flere mapper i hjemmemappen, der hedder noget med Aftershot. Kommandoen finder heller ikke nogen.
Når jeg forsøger at starte programmet, får flg output
Install Path: /opt/AfterShot2(64-bit)
LD_PATH: /opt/AfterShot2(64-bit)/lib:
XLIB_SKIP_ARGB_VISUALS: 1
I have SSE2

Jeg håber, det giver mere mening for jer!
Vh
Karl
Dell Optiplex 7010 3.40GHz x 4, 8 gb ram, 320 gb harddisk + 250 gb disk
Ubuntu 20.04

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Kan ikke starte program

Indlægaf AJenbo » 19. sep 2015, 15:51

Desværre er den eneste information i det output at de computer er produceret efter 2004 :(

Jeg vil forslå du kontakter support for dem der har lavet programmet.

Tilbage til "Tekniske spørgsmål generelt"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster