TTY login blokerer brugen

Her kan du få hjælp til installationen af Ubuntu.
vovsen
Indlæg: 340
Tilmeldt: 25. sep 2009, 21:01
IRC nickname: vovsen
Geografisk sted: GENTOFTE

TTY login blokerer brugen

Indlægaf vovsen » 18. maj 2019, 01:25

Hvordan kan man få maskinen til at arbejde grafisk igen.
Der ligger en del data på den jeg gerne vil have kopieret inden en eventuel ny installation foretages.

AJenbo
Admin
Indlæg: 19910
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: TTY login blokerer brugen

Indlægaf AJenbo » 18. maj 2019, 04:55

Det kommer lidt an på hvorfor du er endt i en TTY, det kan være at systemet er beskeadigt, problemer med grafikkortet eller måske har du startet den i fejl sikker tilstand?
Får du nogen fejlbeskeder eller ligende?

Klaus Rasmussen
Redaktør
Indlæg: 4002
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: TTY login blokerer brugen

Indlægaf Klaus Rasmussen » 18. maj 2019, 08:41

Prøv: Ctrl + Alt + F7 eller Ctrl + Alt + F2
Med Venlig Hilsen
Klaus

Kører Ubuntu 18.04 på Lenovo-H515s, 64bit og 18.10 på HP Probook 4520s, 64 bit.
Manualer til Ubuntu her: http://ubuntu-manual.org/
Ubuntu hjælp her: https://help.ubuntu.com/
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

vovsen
Indlæg: 340
Tilmeldt: 25. sep 2009, 21:01
IRC nickname: vovsen
Geografisk sted: GENTOFTE

Re: TTY login blokerer brugen

Indlægaf vovsen » 18. maj 2019, 12:42

@klaus
Har prøvet begge forslag før og efter at jeg logger ind på maskinen. Intet resultat.
Har prøvet de avancerede startprocesser, hvor filerne testes og pakkerne fejltestes. Efterfulgt af Clean.
Ingen forskel.

Har så logget mig ind på maskinen med bruger og tilhørende password
Jeg kan så se indhold med en dir kommando og Help giver en stribe kommandoer som ikke lige giver mig nogen relevans her og nu. ;-)

Prøvede at starte sudo gparted for at få lidt at vide om maskinens partitionering.
Den kører dual boot med windows 10 (bruges til at få lidt info om OS da jeg supporter i Ældre Sagen)
Denne kommando gav følgende: Unit tmp.mount does not exist, proceeding anyway.
(Gpartedbin:5772): Gtk-WARNING ** 12:18:16.044: cannot open display:
evp@aspire:~$ _ Så er den klar til en ny kommando. Skriver jeg reboot starter maskinen forfra.

Der er meget lidt plads på maskinen (SSD Disk)
Til Linux er der afsat 45,4 GB og 3,8 GB til SWAP. Den kører version 19.04 af UBUNTU, men kom med nogle gylp om rigegeligt lidt plads på disken. Jeg kan måske fjerne nogle 'store' programmer via nogle kommandoer (jeg ikke kender lige nu) fra TTY bordet.

Fejlsikker tilstand: Ja det kan godt være jeg har trigget en sådan. Jeg aner bare ikke hvordan jeg er kommet til det. :-) Og hvordan man så kommer tilbage ud af den er måske løsningen på problemet.
Grafikkortet virker fint i windows, så det er næppe dét der er gået på pension. Maskinen er vist knap år gammel
Det er en ASPIRE A315 hvis det siger jer noget.

vovsen
Indlæg: 340
Tilmeldt: 25. sep 2009, 21:01
IRC nickname: vovsen
Geografisk sted: GENTOFTE

Re: TTY login blokerer brugen

Indlægaf vovsen » 18. maj 2019, 13:17

Det er vel ikke muligt at starte op på en USB stick, og så via dén platform at tilgå disken og hente data over på en anden disk. Jeg skal jo primært have fat i /home/.thunderbird mappen, der indeholder hele mail-systemets data.
En kopi af denne mappe (skjult i filhåndtering : Ctrl+H) kan kopieres ind på en anden UBUNTU-platform, hvorefter alt er ens på maskinerne. Man er så fri for at bruge Duplicity (hedder backup-funktionen vist), hvor data ligger krypteret. (Min post fylder efterhånden ca. 3,8 GB)

Den anden mappe jeg har brug for at kunne kopiere ind på en ny installation er Skrivebordet, med undermapper.

Har jeg fat i de to mapper kan jeg problemfrit installere en ny platform, hvor jeg slanker windows lidt mere => noget mere plads til UBUNTU og så vil /HOME få sin egen partition, så de vigtige data ikke forstyrres af en ny installation.
Jeg plejer (på de andre maskiner) at oprette en partition til "/" og én til /HOME samt normalt 2*RAM til SWAP.
Dette plejer at virke - Er det optiumalt eller kan jeg gøre noget bedre? ;-D

AJenbo
Admin
Indlæg: 19910
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: TTY login blokerer brugen

Indlægaf AJenbo » 18. maj 2019, 14:07

Så vidt jeg kan se er det et AMD Radeon Vega 8 grafikkort i den. Det behøves ikke være pga. der er fysiske problemer med grafikkortet, men der kunne være problemer med den driver der er installeret.

Måske er det gylp for dig, men vi er lidt nød til at se hvad det er for at kunne komme med et kvalificeret bud på hvordan det løses.

Det er fint muligt at køre fra en USB og tilgå disken der fra. Bare start fra installationens disken og vælg "Prøv Ubuntu" frem for "Installer Ubuntu".

Lad installationen selv oprette partitionerne, det lyder ikke som om du har nogen særlig grund til at oprette seperate partitioner. Du kunne sagtens være kommet til at dele plads en op en ikke optimal måde. Det lyder som om du ikke bruger meget mere end 10GB i alt så 45GB lyder ikke som om det er for lidt.

Med denne kommando kan du se hvor meget plads der bliver brugt.

Kode: Vælg alt

df -h


Prøv at starte det grafikse system direkte og se om du får nogen fejl beskeder:

Kode: Vælg alt

sudo startx

vovsen
Indlæg: 340
Tilmeldt: 25. sep 2009, 21:01
IRC nickname: vovsen
Geografisk sted: GENTOFTE

Re: TTY login blokerer brugen

Indlægaf vovsen » 19. maj 2019, 19:36

Den sidste kommando giver ikke umiddelbart nogen fejl.

df .h kommandoen skriver to skærme hvor den sidste jeg kan se starter med følgende:
/dev/loop10 457M 457M 0 100% /snap/wine-plastform/125
slutter med
/dev/loop54 144M 144M 0 100% /snap/gnome-calendar/28
/dev/sda1 96M 57M 40M 59% /boot/efi
tmpfs 379M 0 379M 0% /run/user/1000

Uden at vide hvad ovenstående betyder vil jeg dog gætte på, at sidste linje informerer om at alle resourcer er anvendt. Derfor kan den ikke starte grafikken op.

Den bestående installation er udført med én partition til alt. Grunden til at jeg vil splitte /home fra er den, at jeg så kan lave en OS ny installation uden at forstyrre /home indholdet.

AJenbo
Admin
Indlæg: 19910
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: TTY login blokerer brugen

Indlægaf AJenbo » 19. maj 2019, 19:39

vovsen skrev:Uden at vide hvad ovenstående betyder vil jeg dog gætte på, at sidste linje informerer om at alle resourcer er anvendt. Derfor kan den ikke starte grafikken op.

Det er ikke tilfældet, prøv følgende for at få et lidt mindre output:

Kode: Vælg alt

df -h | grep -v snap

vovsen
Indlæg: 340
Tilmeldt: 25. sep 2009, 21:01
IRC nickname: vovsen
Geografisk sted: GENTOFTE

Re: TTY login blokerer brugen

Indlægaf vovsen » 19. maj 2019, 21:54

OK
Linux partitionen 45G har 4,7G ledig 89% brugt Monteret på /
Så er der Win10 efi boot delen der er brugt 59%
De øvrige ligger på 0 eller 1 %.

Jeg formoder denne info er brugbar. :-) Ellers må jeg jo skrive det hele ned.
Der er 8 linjer med info.

AJenbo
Admin
Indlæg: 19910
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: TTY login blokerer brugen

Indlægaf AJenbo » 20. maj 2019, 00:50

Det lyder ikke som om problemet er opstået pga manglende plads, selv som der ikke er så meget tilbage.

vovsen
Indlæg: 340
Tilmeldt: 25. sep 2009, 21:01
IRC nickname: vovsen
Geografisk sted: GENTOFTE

Re: TTY login blokerer brugen

Indlægaf vovsen » 21. maj 2019, 20:17

OK Så er vi vel dér hvor årsagen er en "systemfejl", hvor udviklerne stikker hovedet i busken.
Problemet kan så kun løses ved at lave en sprit ny installation.

Desværre er ingen blevet klogere af hændelsen.
Jeg laver en ny installation i morgen.
Jeg takker for info om, at man ved hjælp af usb boot stick, kan opsamle nødvendige data til retablering af arbejdsstationen.

AJenbo
Admin
Indlæg: 19910
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: TTY login blokerer brugen

Indlægaf AJenbo » 21. maj 2019, 21:47

vovsen skrev:Problemet kan så kun løses ved at lave en sprit ny installation.

Jeg er ikke helt sikker på hvad du hentyder til, men skal gerne prøve nogle flere ting for at få nogle oplysniger fra den. Hvad får du hvis du eks. køre:

Kode: Vælg alt

dmesg

Tilbage til "Installation"

Hvem er online

Brugere der læser dette forum: Ingen og 0 gæster