Vælge fast lydoutput

Få hjælp til at sætte programmer eller funktioner op.
Simon Justesen
Indlæg: 18
Tilmeldt: 21. sep 2013, 13:33
IRC nickname: simmdk
Geografisk sted: Randers, Danmark

Vælge fast lydoutput

Indlægaf Simon Justesen » 9. maj 2018, 11:01

Er der nogen nem måde at vælge et fastdefineret lydoutput? Jeg har det problem, at Ubuntu (18.04) konsekvent vælger min mikrofon som output (ja, den er god nok, der er noget line-out hejs der også!) fremfor line-out udgangen på lydkortet, så jeg har aldrig lyd i mine højttalere, medmindre jeg selv aktivt vælger det.

Jeg har set en guide med en ret kompleks konfiguration af PulseAudio i terminalen skulle gøre det, men kan det virkelig passe, det skal være så bøvlet?

Simon Justesen
Indlæg: 18
Tilmeldt: 21. sep 2013, 13:33
IRC nickname: simmdk
Geografisk sted: Randers, Danmark

Re: Vælge fast lydoutput

Indlægaf Simon Justesen » 9. maj 2018, 11:15

Her er guiden i øvrigt....
https://askubuntu.com/questions/398030/ ... le_rich_qa

(Jeg kan ikke i øvrigt ikke finde den "Multimedia Systems Selector", der nævnes længere nede, så ville problemet have været simpelt at løse ;) "gnome-media"-pakken lader sig ikke installere)

Klaus Rasmussen
Redaktør
Indlæg: 3586
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Vælge fast lydoutput

Indlægaf Klaus Rasmussen » 9. maj 2018, 14:25

Hvad siger:

Kode: Vælg alt

lspci | grep Audio

Lad os se screen-print af: Systemindstillinger - Lyd.
Med Venlig Hilsen
Klaus

Kører Ubuntu 18.04 på Lenovo-H515s, 64bit og på HP Probook 4520s.
Manualer til Ubuntu her: http://ubuntu-manual.org/
Ubuntu hjælp her: https://help.ubuntu.com/
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

Simon Justesen
Indlæg: 18
Tilmeldt: 21. sep 2013, 13:33
IRC nickname: simmdk
Geografisk sted: Randers, Danmark

Re: Vælge fast lydoutput

Indlægaf Simon Justesen » 9. maj 2018, 17:13

De er her - men altså, problemet er ikke, at jeg ikke har lyd, men at Ubuntu vælger et forkert output - det burde være muligt at sætte "Line-Out" til default, så den står der ved opstart

Udskrift af lspci | grep "Audio"
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)
Vedhæftede filer
Skærmbillede fra 2018-05-09 17-08-28.png
Skærmbillede fra 2018-05-09 17-08-28.png (82.49 KiB) Vist 203 gange

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Vælge fast lydoutput

Indlægaf zob » 10. maj 2018, 01:16

Hej

Det burde vel virke ved at du vælger det lydkort du ønsker der hvor du står. Men da det ikke lader til at virke for dig, er vi nok nødt til at skal have fat i terminal. I første omgang hvilke lydkort (med afspilningsmuligheder) har dit system:

Kode: Vælg alt

aplay -l

Måske også:

Kode: Vælg alt

cat /proc/asound/cards

Bare copy paste resultatet herind, gerne i code tags.

Så må vi se om vi kan genkende hvilket kort det er du ønsker er default og hvilket du absolut ikke ønsker er default, inden vi går videre.

Simon Justesen
Indlæg: 18
Tilmeldt: 21. sep 2013, 13:33
IRC nickname: simmdk
Geografisk sted: Randers, Danmark

Re: Vælge fast lydoutput

Indlægaf Simon Justesen » 10. maj 2018, 02:38

Vi prøver ;)

Output fra aplay:

Kode: Vælg alt

**** Liste over PLAYBACK-hardwareenheder ****
lydkort 0: PCH [HDA Intel PCH], enhed 0: ALC887-VD Analog [ALC887-VD Analog]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 1: NVidia [HDA NVidia], enhed 3: HDMI 0 [HDMI 0]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 1: NVidia [HDA NVidia], enhed 7: HDMI 1 [HDMI 1]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 1: NVidia [HDA NVidia], enhed 8: HDMI 2 [HDMI 2]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 1: NVidia [HDA NVidia], enhed 9: HDMI 3 [HDMI 3]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 3: Microphone [Yeti Stereo Microphone], enhed 0: USB Audio [USB Audio]
  Underenheder: 1/1
  Underenhed #0: subdevice #0
lydkort 4: Gamin [Corsair VOID PRO Wireless Gamin], enhed 0: USB Audio [USB Audio]
  Underenheder: 1/1
  Underenhed #0: subdevice #0


... og $ cat /proc/asound/cards

Kode: Vælg alt

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf220000 irq 125
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdf080000 irq 17
 2 [C930e          ]: USB-Audio - Logitech Webcam C930e
                      Logitech Webcam C930e at usb-0000:00:14.0-3, high speed
 3 [Microphone     ]: USB-Audio - Yeti Stereo Microphone
                      Blue Microphones Yeti Stereo Microphone at usb-0000:00:14.0-7, full speed
 4 [Gamin          ]: USB-Audio - Corsair VOID PRO Wireless Gamin
                      Corsair Corsair VOID PRO Wireless Gamin at usb-0000:00:14.0-10, full speed

Det er jo så nok lydkort 0, der er interessant, eftersom det er der mine højttalere er koblet på. Alt andet er via USB. Og ja, hvis jeg sætter output til Line-Out så hopper Ubuntu tilbage på Yeti'en efter reboot

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Vælge fast lydoutput

Indlægaf zob » 10. maj 2018, 20:23

Pinligt nok, sad jeg på en windows maskine da jeg skrev, jeg huskede forkert og i virkeligheden var det en anden fil der var den interessante. Så giv os lige denne her også:

Kode: Vælg alt

cat /proc/asound/modules

Og hvis vi skal være helt sikre på at kunne (eller ikke kunne) løse det i næste hug, så kom med denne her også:

Kode: Vælg alt

lsmod | grep snd


For at du ikke skal sidde også famle i blinde, så lad mig sige med det samme at formålet er at gøre det samme som Canonical allerede har gjort med visse problematiske lydkort i bunden af følgende fil:

Kode: Vælg alt

cat /etc/modprobe.d/alsa-base.conf

Du må faktisk gerne copy-paste indholdet af den også, så kan vi se hvor du skal sætte ind. Du kan nok se at der i bunden af filen arbejdes på at få diverse lydkort til at holde sig væk, så det er dét der er min strategi for dig. Du må undskylde at jeg ikke kender nogen nemmere løsning.

Nå ok. Jeg kunne læse mig til at der er en hovedtelefon udgang også i din mikrofon, så overfor systemet er den både en ind- og en udgang. Ellers tænkte jeg at der var noget helt galt.

Simon Justesen
Indlæg: 18
Tilmeldt: 21. sep 2013, 13:33
IRC nickname: simmdk
Geografisk sted: Randers, Danmark

Re: Vælge fast lydoutput

Indlægaf Simon Justesen » 11. maj 2018, 16:45

Kode: Vælg alt

cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
 2 snd_usb_audio
 3 snd_usb_audio
 4 snd_usb_audio
 


Kode: Vælg alt

lsmod | grep snd
snd_usb_audio         196608  10
snd_usbmidi_lib        32768  1 snd_usb_audio
snd_hda_codec_hdmi     49152  1
snd_seq_midi           16384  0
snd_hda_codec_realtek   102400  1
snd_seq_midi_event     16384  1 snd_seq_midi
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_rawmidi            32768  2 snd_seq_midi,snd_usbmidi_lib
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
snd_hda_intel          40960  8
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              20480  2 snd_hda_codec,snd_usb_audio
snd_pcm                98304  5 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core,snd_hda_codec_hdmi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  49 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd


og til sidst alsa-base.conf

Kode: Vælg alt

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


Løsningen skal helst være så den pågældende enhed stadig virke, men må nok erkende jeg har tabt overblikket ;)
hvis jeg "forcer" snd_hda_intel til index=0, så skulle den sætte den først i køen, ikke?
"options snd_hda_intel index=0"

Simon Justesen
Indlæg: 18
Tilmeldt: 21. sep 2013, 13:33
IRC nickname: simmdk
Geografisk sted: Randers, Danmark

Re: Vælge fast lydoutput

Indlægaf Simon Justesen » 11. maj 2018, 20:29

Som en lille sidenote (se vedhæftede), så har jeg opfordret Canonical til at lave en lidt mere brugervenlig udgave til en senere udgave, spændende om der kommer noget ud af det.
Vedhæftede filer
ubuntu-forum.png
ubuntu-forum.png (74.23 KiB) Vist 95 gange

AJenbo
Admin
Indlæg: 19498
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Vælge fast lydoutput

Indlægaf AJenbo » 11. maj 2018, 20:45

Fedt :)

Tilbage til "Opsætning"

Hvem er online

Brugere der læser dette forum: Ingen og 0 gæster