Boot problem efter slettet Windows 10 Emnet er løst

Her kan du få hjælp til installationen af Ubuntu.
Biotopen
Indlæg: 5
Tilmeldt: 24. feb 2018, 13:23

Boot problem efter slettet Windows 10

Indlægaf Biotopen » 24. feb 2018, 13:46

En lavpris bærbar med 32 GB SSD og Windows 10 fik ustandselige påmindelser om "anniversary update", men det var der ikke plads til. Det krævede 8 GB ledig plads, og selv da den blev renset for alt der ikke var Windows, var der stadig ikke plads. SSD'en kan ikke udskiftes med en større, og producenten skældes ud for at lægge Windows 10 på for små maskiner:
https://answers.microsoft.com/en-us/win ... 469?auth=1
hvorefter en anden på kommentartråden forklarer at det ikke skyldes producenten, men Microsofts restriktive licenspolitik.
Nå, så vælger man at erstatte Windows med en Linux distro, som jeg tit har gjort uden problemer (ikke før med Windows 10). UEFI skal somme tider omstilles til Legacy.
Men det gik ikke denne gang! Distroen kører fra DVD'en og kan installeres, men ved genstart har man ikke længere adgang til BIOS opsætning, kun valget mellem 2 muligheder på Boot Menuen (Phoenix SecureCore Technology):
eMMC Disk: SanDisk iNAND 32 GB - eller: Windows Boot Manager
og så kan man ikke kommer længere.
Jeg installerede Ubuntu 14.04, Mint 18.02, Mint 18.3, Ubuntu Gnome 16.04.3, Fedora 23, alle med samme resultat. Kan også prøve med Open Suse, Debian, Lubuntu osv., men problemet er vist uafhængigt af distro.
Med det eksterne DVD drev med installationsdisken tilkoblet, kommer også den op på menuen, og OS kan køre fra DVD'en, men ikke fra den installerede version.
Har læst, at Microsoft forsøger at gøre de præinstallerede maskiner utilgængelige for Linux. Det lyder sandsynligt, men er i så fald først sket for nylig.

Spørgsmålene er:
- Er maskinen stadig inficeret med Windows-rester? Har Windows erobret BIOS/UEFI?
- Kan BIOS/UEFI udskiftes, redigeres eller bypasses, kan GRUB eller andet gøre noget ved det?
- Findes der er løsning, eller er computeren blevet til teknologiskrot?
Det er en Lenovo Ideapad 100S.
Mvh LK

AJenbo
Admin
Indlæg: 19627
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Boot problem efter slettet Windows 10

Indlægaf AJenbo » 24. feb 2018, 18:15

Hej Lars og velkommen til forummet

Det er sådan set ikke Microsoft der forsøger at forhindre at andet installeres, men nogle producenter laver en dårlig UEFI hvor de ikke tester om andre operativ systemer kan installeres.

Problemet lyder til at være at GRUB ikke bliver installeret som et opstarts valg i UEFI.

UEFI står for at starte hardware så du kan ikke undvære den del, om muligt kan du se om producenten har lavet en opdatering der løser problemet. Der findes også et alternativ via CoreBoot, men da dette software står for at starte hardware skal det tilpasses hvert individuelle system så det kan kun installeres hvis nogen i forvejen har fået det til at fungere med lige den model du har. Da dette er en omstændig process og der meget sjældent er dokumentation for hardware er det kun en få tal af systemer hvor de er lavet til, og S100 er ikke på listen:
https://www.coreboot.org/Supported_Motherboards

Så vidt jeg kan læse mig til har maskinen det problem at UEFI er 32bit og man der for ikke kan installere 64bit GRUB. Selve maskinen er dog 64bit. En mulig løsning er at lave en modificeret udgave af Ubuntu 64bit der har en opstart fra 32bit udgaven. Men det nemmeste er nok blot at installere en 32bit udgave, der er dog visse begrænsninger ved 32bit udgaven da blandt andet Google ikke længere laver Chrome i en 32bit udgave. Men måske hvis du er heldig kan du efterfølgende lave en 64bit udgave som så vil fortsætte med a starte vi opstarts indlæseren fra 32bit udgaven.

En anden ting du kan prøver er, som du selv henviser til, at slå UEFI i legacy tilstand (skal også være sat under installationen), så vil den ikke bruge egne opstarts programmer men forsøge at starte direkte fra disken.

Jeg vil i øvrigt råde dig til Ubuntu 16.04 eller nyre på maskiner med UEFI.

Du kan også prøve at deaktivere SecureBoot, normalt burde det ikke være et problem for Ubuntu, men måske er der problemer med UEFI i din maskiner.

Biotopen
Indlæg: 5
Tilmeldt: 24. feb 2018, 13:23

Re: Boot problem efter slettet Windows 10

Indlægaf Biotopen » 24. feb 2018, 18:51

Tak for en håndfuld gode råd, som jeg vil prøve i rækkefølge. Jeg kan klare mig med 32bit, og behøver ikke Chrome, så det første forsøg bliver en 32bit Ubuntu. Så kan jeg senere prøve med en Ubuntu 16.04 eller nyere.

AJenbo
Admin
Indlæg: 19627
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Boot problem efter slettet Windows 10

Indlægaf AJenbo » 25. feb 2018, 11:49

Her er linket til 32bit udgaven af Ubuntu 16.04:
http://releases.ubuntu.com/16.04/ubuntu ... p-i386.iso

Biotopen
Indlæg: 5
Tilmeldt: 24. feb 2018, 13:23

Re: Boot problem efter slettet Windows 10

Indlægaf Biotopen » 25. feb 2018, 18:07

Tak for link til 16.04!
Har nu afprøvet 14.04 og 16.04 i 32GB, desværre uden fremskridt. Ender hver gang i en Boot menu der ikke giver adgang til yderligere.

Ved forsøg på opstart kommer denne fejlmeddelelse:

[ 0.274140] ACPI Error: No handler for Region [ECF2] (f44928a0) [EmbeddedControl] (20160930/evregion-166)
[ 0.274290] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160930/exfldio-299)
[ 0.274422] ACPI Error: Method parse/execution failed [/SB.PCI0.LPCB.EC0._REG] (Node f4495c90), AE_NOT_EXIST (209160930/psparse-543)
[ 0.275013] ACPI Error: No handler for Region [ECF2] (f44928a0) [EmbeddedControl] (20160930/evregion-166)
[ 0.275148] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160930/exfldio-299)
[ 0.275277] ACPI Error: Method parse/execution failed [/SB.PCI0.LPCB.EC0._REG] (Node f4495c90), AE_NOT_EXIST (209160930/psparse-543)
[*** ] A start job is running for Ubuntu live CD installer (1min / no limit)

Giver det nogen forklaring?

Her kommer en oversigt over BIOS indstillingerne (default indstillinger valgt, bortset fra Legacy):

Information:
Product Name Lenovo ideapad 100S-14IBR
BIOS Version E4CN28WW
EC Version E4CN28WW
MTM 80R9001AMX
Lenovo SN YD00PDP5
UUID Number 2C6E852C-47SF-2016-0312-000608000000

CPU Intel(R) Celeron (R) CPU N3050 @ 1.60GHz
System Memory 2048 MB
Hard disk SanDisk iNAND 32GB

Preinstalled OS License SDK0K04663 WIN
OA3 Key 3259104686639
OA2 N

Configuration:
System Time [14:07:01]
System Date [02/25/2018]

USB Legacy [Enabled]
Wireless [Enabled]
Hotkey Mode [Enabled]
Bios Black Flash [Disabled]

Security:
Administrator Password Cleared
User Password Cleared

Set Administrator Password [Enter]

Intel Platform Trust Technology [Enabled]
Clear Intel PTT Key [Clear Intel PTT Key]

Secure Boot [Enabled]
Secure Boot Status Enabled
Platform Mode User Mode
Secure Boot Mode Standard Mode
Reset to Setup Mode [Enter]
Restore Factory Key [Enter]

Boot:
Boot Mode [Legacy Support]
Boot Priority [Legacy First]
USB Boot [Enabled]
PXE Boot to LAN [Enabled]
Boot Priority Order
1. Windows Boot Manager
2. ATA HDD:
3. eMMC Disk: SanDisk iNAND 32GB
4. USB HDD:
5. PCI LAN:
6. USB FDD:
7. USB CD: TSSTcorp CDDVDW SE-S224Q

Exit:
Exit Saving Changes
Exit Discarding Changes
Discard Changes
Save Changes

Load Default Settings
OS Optimized Defaults [Disabled]


(Forskellige Boot Priority Orders har været forsøgt. OS Optimized Defaults fører til UEFI mode).

AJenbo
Admin
Indlæg: 19627
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Boot problem efter slettet Windows 10

Indlægaf AJenbo » 25. feb 2018, 20:14

Prøv at deaktivere Secure Boot, og prøv både med og uden legacy. Start med 32bit (det er ikke 32GB).

Biotopen
Indlæg: 5
Tilmeldt: 24. feb 2018, 13:23

Re: Boot problem efter slettet Windows 10  Emnet er løst

Indlægaf Biotopen » 7. mar 2018, 16:19

Skylder at melde tilbage, med tak for hjælpen.
(Nej, det er selvfølgelig ikke 32GB med 32bit, der er jo en faktor 8 milliarder til forskel).
Alt blev afprøvet, men jeg måtte gå til en prof. reparatør med gode virksomhedsreferencer. Problemet med pågældende pc er, at den har 64bit processor men 32bitBIOS, og den kombination skulle kræve at man går ind og ændrer i Linux kernen. Det giver hverken mening eller økonomi med den billige maskine, så løsningen blev at geninstallere Windows 10, altså tilbage til udgangspunktet.
Nu var det heldigvis ikke min egen, så min bekendte som jeg troede at kunne hjælpe, må køre videre med den.
Mvh

Brugeravatar
Kurt Christensen
Indlæg: 2239
Tilmeldt: 12. feb 2011, 13:22
IRC nickname: How to be me

Re: Boot problem efter slettet Windows 10

Indlægaf Kurt Christensen » 7. mar 2018, 17:05

Biotopen skrev:Skylder at melde tilbage, med tak for hjælpen.
(Nej, det er selvfølgelig ikke 32GB med 32bit, der er jo en faktor 8 milliarder til forskel).
Alt blev afprøvet, men jeg måtte gå til en prof. reparatør med gode virksomhedsreferencer. Problemet med pågældende pc er, at den har 64bit processor men 32bitBIOS, og den kombination skulle kræve at man går ind og ændrer i Linux kernen. Det giver hverken mening eller økonomi med den billige maskine, så løsningen blev at geninstallere Windows 10, altså tilbage til udgangspunktet.
Nu var det heldigvis ikke min egen, så min bekendte som jeg troede at kunne hjælpe, må køre videre med den.
Mvh

Du skal vel ikke ændre i kernen hvis du havde forsøgt med dette link?
http://releases.ubuntu.com/16.04/ubuntu ... p-i386.iso
Som jo er 32 bit.
BRUGERFLADEBRUGER med Ubuntu 17.10 64 bit :O)
Laptop Compaq Presario CQ70-230EO
Intel(R) Pentium(R) Dual CPU T3400 @ 2.16GHz, 4GB ram, GeForce 9200M GE/PCIe/SSE2

Klaus Rasmussen
Redaktør
Indlæg: 3674
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Boot problem efter slettet Windows 10

Indlægaf Klaus Rasmussen » 7. mar 2018, 19:14

Kurt Christensen skrev:Du skal vel ikke ændre i kernen hvis du havde forsøgt med dette link?
http://releases.ubuntu.com/16.04/ubuntu ... p-i386.iso
Som jo er 32 bit.

Humlen er jo, at du kan ikke installere en 64 bit version på et 32 bit afhængigt system, men det omvendte er OK.
Med Venlig Hilsen
Klaus

Kører Ubuntu 18.04 på Lenovo-H515s, 64bit og på HP Probook 4520s.
Manualer til Ubuntu her: http://ubuntu-manual.org/
Ubuntu hjælp her: https://help.ubuntu.com/
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

Biotopen
Indlæg: 5
Tilmeldt: 24. feb 2018, 13:23

Re: Boot problem efter slettet Windows 10

Indlægaf Biotopen » 9. mar 2018, 20:02

Tak for kommentarer! Jeg er med, men havde også forsøgt at installere diverse 32bit versioner uden held. Tid og sportsånd randt ud, så det blev som beskrevet, beklager. Men som sagt, det var første gang jeg mødte problemet, efter at have installeret løs i årevis på forskellige skæve systemer.
Mvh

Danniella
Indlæg: 2
Tilmeldt: 12. maj 2018, 23:52

Re: Boot problem efter slettet Windows 10

Indlægaf Danniella » 13. maj 2018, 00:53

Havde den samme type computer og var succesful med installation af 32 bit version. tak for link!
Sur ung pige der render rundt i ubuntu tågerne! Prøver at lære om freeware operativsystemer og webservere og fritidswebmaster hos en Kosmetolog!

Tilbage til "Installation"

Hvem er online

Brugere der læser dette forum: Google [Bot] og 0 gæster