Disabling resampling ifm med en DAC Emnet er løst

Forum for support til grafik og lydkort.
axelf
Indlæg: 72
Tilmeldt: 1. jul 2014, 10:58

Disabling resampling ifm med en DAC

Indlægaf axelf » 10. nov 2017, 10:56

Hi.
Anvender en DAC i forbindelse med mit musikanlæg. Har brug for at tilføje en linie i audio_output sectionens .mpdconf file med linien auto_resampler "no".
Please, hvordan gør jeg det?
Med venlig Hilsen
Axel

Lifebook E8420 Ubuntu 17.10 64-bit
Processor: Intel® Core™2 Duo CPU P8600 @ 2.40GHz × 2
Grafik: Mobile Intel® GM45 Express Chipset

LIFEBOOK-C1320 Ubuntu 16.04 32-bit(musik streaming)
Processor: Intel® Pentium(R) M processor 1.73GHz
Grafik: Intel® 915GM x86/MMX/SSE2

Klaus Rasmussen
Redaktør
Indlæg: 3307
Tilmeldt: 26. apr 2010, 02:40
IRC nickname: ClaudiuS
Geografisk sted: Nyborg [fyn]

Re: Disabling resampling ifm med en DAC

Indlægaf Klaus Rasmussen » 10. nov 2017, 15:45

1. Kør:

Kode: Vælg alt

sudo gedit /vlc/plugins/audio_output/mpd.conf

2. Så starter Gedit: Indsæt:

Kode: Vælg alt

auto_resampler "no"

3. Gem fil.

4. Job done.
Med Venlig Hilsen
Klaus

Kører Ubuntu 17.10 på Lenovo-H515s, 64bit
Manualer til Ubuntu her: http://ubuntu-manual.org/
Ubuntu hjælp her: https://help.ubuntu.com/
Gratis Ubuntumagasin: http://fullcirclemagazine.org/
MEGA Share: https://mega.nz/#F!XNM1ALpL!G_CEVUUE9ZvotKPa4o4PLA

zob
Redaktør
Indlæg: 4424
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Disabling resampling ifm med en DAC

Indlægaf zob » 10. nov 2017, 16:33

Jeg indrømmer at det måske er lidt mangelfuldt med informationen om hvad og hvorfor. Det lyder lidt som om det er et råd der er blevet givet et sted og så kunne man jo godt have ladet os kikke med så vi kunne være sikre på hvad det var der skulle rettes. Nuvel. Jeg tænker at det er mere sandsynlidt (men det er blot et gæt) at rettelsen hører til i filen

Kode: Vælg alt

/etc/mpd.conf

Så mon ikke det nærmere skal være noget i stil med

Kode: Vælg alt

gksu gedit /etc/mpd.conf

I denne fil vil du kunne finde eller oprette et afsnit der ligner noget i stil med

Kode: Vælg alt

audio_output {
  auto_resample "no"
}
Der står muligvis andet inden for tuborgklammerne, men hvis ikke der står auto_resample "no", så tilføjer du det bare. Hvis det allerede står det, ja så er der jo ikke mere du skal gøre her.
Hvis ikke du har en /etc/mpd.conf fil, så må du lige fortælle hvad det er du er i gang med.

axelf
Indlæg: 72
Tilmeldt: 1. jul 2014, 10:58

Re: Disabling resampling ifm med en DAC

Indlægaf axelf » 14. nov 2017, 11:24

Hej begge.
Tak for svarene.
Kan godt se at det er lidt kryptisk, og at andre måske kunne have glæde af denne tråd. Jeg har en Henry Audio DAC som bruges på sammen med en Linux pc, og i den forbindelse skriver Henry audio følgende i deres manual,

"Most modern operating systems, with the exception of iOS, will automatically
resample your digital music as it is being played back. This is not a major issue
but it may improve sound quality to turn it off. Some player programs disable
resampling on their own. On Windows using the protocols WASAPI or ASIO
disables resampling.
Because most digital music is recorded at the CD's sample rate of 44.1ksps, you
are recommended to set this as the default sample rate for the DAC.
Linux and MPD
If you use Linux and MPD make sure you enter the following line in the
audio_output section of your .mpdconf file:
auto_resample "no"
This will disable resampling, and you don't need to set a default rate. "
Om jeg kan høre forskel ved jeg endnu ikke, men når man er lidt HIFI nørdet, skal alt jo trimmes til optimal ydelse :-)
Med venlig Hilsen
Axel

Lifebook E8420 Ubuntu 17.10 64-bit
Processor: Intel® Core™2 Duo CPU P8600 @ 2.40GHz × 2
Grafik: Mobile Intel® GM45 Express Chipset

LIFEBOOK-C1320 Ubuntu 16.04 32-bit(musik streaming)
Processor: Intel® Pentium(R) M processor 1.73GHz
Grafik: Intel® 915GM x86/MMX/SSE2

zob
Redaktør
Indlæg: 4424
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Disabling resampling ifm med en DAC

Indlægaf zob » 14. nov 2017, 12:16

Du kan se her, hvorfor nogen anbefaler det. Det kunne se ud som om det er en ydelses-optimerings-ting mere end en audio-optimerings-ting.
https://wiki.archlinux.org/index.php/Mu ... _with_ALSA

AJenbo
Admin
Indlæg: 19121
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Disabling resampling ifm med en DAC  Emnet er løst

Indlægaf AJenbo » 14. nov 2017, 13:14

Du skal blot oprette filen .mpdconf i din hjemme mappe og indsætte den linje der nævnes.
Det kan gøres med følgende kommando:

Kode: Vælg alt

echo 'auto_resample "no"' >> ~/.mpdconf

Men bruger du MDP? Det er ikke noget der er i Ubuntu som standard. Så hvis ikke du har installeret "Music Player Daemon" behøves du ikke gøre noget, som der står "Hvis du bruger MDP på Linux skal du"

axelf
Indlæg: 72
Tilmeldt: 1. jul 2014, 10:58

Re: Disabling resampling ifm med en DAC

Indlægaf axelf » 17. nov 2017, 16:44

Hej igen.
Jeg bruger Rythmebox i.f.m. afspilning af gemte CDér, og har derfor - som skrevet - ikke brug for at foretage denne ændring. Havde lige overset denne detalje, men mange tak for jeres input.
Med venlig Hilsen
Axel

Lifebook E8420 Ubuntu 17.10 64-bit
Processor: Intel® Core™2 Duo CPU P8600 @ 2.40GHz × 2
Grafik: Mobile Intel® GM45 Express Chipset

LIFEBOOK-C1320 Ubuntu 16.04 32-bit(musik streaming)
Processor: Intel® Pentium(R) M processor 1.73GHz
Grafik: Intel® 915GM x86/MMX/SSE2

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: Ingen og 0 gæster