SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 - NU!

Nyheder om Open Source, Ubuntu, andre distributioner og meget mere.
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 - NU!

Indlæg af lath »

START: --- EDIT --- EDIT --- EDIT --- EDIT --- EDIT --- EDIT ---
Opdateringen er ude i pakkearkiverne nu, spørg for at opdatere dine installerede pakker, så er alt i orden.
SLUT: --- EDIT --- EDIT --- EDIT --- EDIT --- EDIT --- EDIT ---

Mozilla Foundation har annonceret at der er et sikkerhedshul i den nye Firefox (FF) 16, og de anbefaler derfor at med nedgraderer tilversion 15 af Firefox.
http://www.version2.dk/artikel/ny-firefox-16-paa-gaden-med-sikkerhedshul-mozilla-advarer-mod-opgradere-48236

Lige i dag har der været opgraderinger, hvor man kunne installere FF 16, hvilket jeg så har undladt at gøre.

Jeg er lige i gang med at finde ud af hvordan man downgrader til en tidligere version, og låser en pakke (der er hos mig 5 pakker der skal versionslåses).

Hvis du ved hvordan så post lige her i tråden.

/Lars

Edit: jeg har har fundet noget brugbart terminaltrylleri der kan gøre det, men for en anden pakke, og skal lige teste det af først.
Senest rettet af lath 12. okt 2012, 11:27, rettet i alt 1 gang.
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
Stra
Indlæg: 3105
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af Stra »

stra
Bruger Ubuntu 22.04 og 22.10 + lubuntu 22.10
Ivan
Indlæg: 1133
Tilmeldt: 6. nov 2009, 17:05
Geografisk sted: Rudkøbing

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af Ivan »

Jeg har 16.0.1 men det er måske fordi at jeg bruger https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa
Arch på Toshiba Satellite C660-1NT og Acer Aspire One 532h
Manjaro på hjemmerullet pc.
AJenbo
Admin
Indlæg: 20861
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af AJenbo »

Synaptic kan bruges til at låse pakker på en version
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af lath »

Kender godt til det med synaptic, men jeg foretrækker at bruge terminalen, ellers tak for tippet.

Jeg har ikke fået opdateringen endnu, og jeg har lige kørt en

Kode: Vælg alt

sudo apt-get update

Den tilbyder stadigvæk kun version 16.0 af Firefox:
Tilgængelige version: 16.0+build1-0ubuntu0.12.04.1


/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

versionedgradering for pakker

Indlæg af lath »

Bemærk at jeg har Ubuntu 12.04.1 LTS i386, har du ikke 12.04/12.04.1 i386 skal du selv køre første kommando umodificeret, og så trække versionsnummeret ud, og bruge det i den 2. kommando i stedet for det versionsnummer jeg bruger.

Her noget af det:
Man starter med at køre den her kommando (bemærk at sudo ikke er nødvendig, da vi ikke ændrer på noget i systemet):

Kode: Vælg alt

apt-cache showpkg  firefox

og har man Firefox 15.0.1+build1-0ubuntu0.12.04.1 ser det således ud:
Package: firefox
Versions:
16.0+build1-0ubuntu0.12.04.1 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise-updates_main_binary-i386_Packages) (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise-security_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
MD5: 46b619f510631c4693dc09c1a3778a55
Description Language: en
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_i18n_Translation-en
MD5: 46b619f510631c4693dc09c1a3778a55

15.0.1+build1-0ubuntu0.12.04.1 (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
MD5: 46b619f510631c4693dc09c1a3778a55
Description Language: en
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_i18n_Translation-en
MD5: 46b619f510631c4693dc09c1a3778a55

11.0+build1-0ubuntu4 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages
MD5: 46b619f510631c4693dc09c1a3778a55
Description Language: en
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_i18n_Translation-en
MD5: 46b619f510631c4693dc09c1a3778a55


Reverse Depends:
firefox-gnome-support,firefox
rhythmbox-mozilla,firefox
ubuntu-online-tour,firefox
flashplugin-installer,firefox
mozilla-libreoffice,firefox
mozilla-libreoffice,firefox
cairo-dock-core,firefox
xul-ext-ubufox,firefox
xul-ext-ubufox,firefox 9.0
totem-mozilla,firefox
rhythmbox-mozilla,firefox
libreoffice,firefox
firefox-gnome-support,firefox
firefox-globalmenu,firefox 16.0+build1-0ubuntu0.12.04.1
firefox-dev,firefox 16.0+build1-0ubuntu0.12.04.1
firefox-dbg,firefox 16.0+build1-0ubuntu0.12.04.1
firefox-branding,firefox 9.0
abrowser-branding,firefox 9.0
abrowser,firefox 9.0
flashplugin-installer,firefox
xubuntu-desktop,firefox
xsane,firefox
xfig-doc,firefox
wysihtml-el,firefox
webhttrack,firefox
ubuntustudio-desktop,firefox
ubuntu-sugar-remix,firefox
sugar-firefox-activity,firefox
screenlets-pack-basic,firefox
screenlets-pack-all,firefox
pytrainer,firefox
nip2,firefox
mozplugger,firefox
mozilla-libreoffice,firefox
mozilla-libreoffice,firefox
mediatomb,firefox
libknopflerfish-osgi-java-doc,firefox
libjibx1.2-java-doc,firefox
libjibx1.1-java-doc,firefox
jsmath-fonts,firefox
gosa-desktop,firefox
gnome-do-plugins,firefox
gecko-mediaplayer,firefox
gcu-plugin,firefox
firefox-launchpad-plugin,firefox
djview-plugin,firefox
djview-plugin,firefox
dhelp,firefox
deejayd-webui-extension,firefox
chemical-structures,firefox
centerim-utf8,firefox
centerim-fribidi,firefox
centerim,firefox
cairo-dock-core,firefox
browser-plugin-packagekit,firefox 3.0
bluefish,firefox
ardour-i686,firefox
ardour,firefox
xul-ext-ubufox,firefox
xul-ext-ubufox,firefox 4.0~b6
xul-ext-mozvoikko,firefox 4.0
ubuntu-desktop,firefox
totem-mozilla,firefox
rhythmbox-mozilla,firefox
libreoffice,firefox
hunspell-vi,firefox 2.0.0.3-2
hunspell-uz,firefox 2.0.0.3-2
hunspell-sr,firefox 2.0.0.3-2
hunspell-sh,firefox 2.0.0.3-2
hunspell-ro,firefox 2.0.0.3-2
hunspell-ne,firefox 2.0.0.3-2
hunspell-hu,firefox 2.0.0.3-2
hunspell-gl-es,firefox 2.0.0.3-2
hunspell-fr,firefox 2.0.0.3-2
hunspell-eu-es,firefox 2.0.0.3-2
hunspell-en-us,firefox 2.0.0.3-2
hunspell-en-ca,firefox 2.0.0.3-2
hunspell-de-de,firefox 2.0.0.3-2
hunspell-de-ch,firefox 2.0.0.3-2
hunspell-de-at,firefox 2.0.0.3-2
hunspell-da,firefox 2.0.0.3-2
firefox-gnome-support,firefox
firefox-globalmenu,firefox 11.0+build1-0ubuntu4
firefox-dev,firefox 11.0+build1-0ubuntu4
firefox-dbg,firefox 11.0+build1-0ubuntu4
firefox-branding,firefox 9.0
abrowser-branding,firefox 9.0
abrowser,firefox 9.0
Dependencies:
16.0+build1-0ubuntu0.12.04.1 - lsb-release (0 (null)) libasound2 (2 1.0.23) libatk1.0-0 (2 1.12.4) libc6 (2 2.15) libcairo2 (2 1.2.4) libdbus-1-3 (2 1.0.2) libdbus-glib-1-2 (2 0.78 ) libfontconfig1 (2 2.8.0) libfreetype6 (2 2.3.9) libgcc1 (2 1:4.1.1) libgdk-pixbuf2.0-0 (2 2.22.0) libglib2.0-0 (2 2.31.8 ) libgtk2.0-0 (2 2.24.0) libnotify4 (2 0.7.0) libpango1.0-0 (2 1.14.0) libstartup-notification0 (2 0.8 ) libstdc++6 (2 4.6) libx11-6 (0 (null)) libxext6 (0 (null)) libxrender1 (0 (null)) libxt6 (0 (null)) latex-xft-fonts (0 (null)) libthai0 (0 (null)) firefox-gnome-support (0 (null)) xul-ext-ubufox (0 (null)) firefox-globalmenu (0 (null)) libcanberra0 (0 (null)) gcu-plugin (1 0.12.10-1ubuntu1) abrowser (1 4.0~b11+build3+nobinonly-0ubuntu1) abrowser-branding (1 4.0~b11+build3+nobinonly-0ubuntu1) adobe-flashplugin (1 11.1.102.63-0precise1) firefox-branding (1 4.0~b11+build3+nobinonly-0ubuntu1) flashplugin-installer (1 11.1.102.63ubuntu1) abrowser (0 (null)) abrowser-branding (0 (null)) firefox-branding (0 (null)) kubuntu-firefox-installer (0 (null))
15.0.1+build1-0ubuntu0.12.04.1 - lsb-release (0 (null)) libasound2 (2 1.0.23) libatk1.0-0 (2 1.12.4) libc6 (2 2.15) libcairo2 (2 1.2.4) libdbus-1-3 (2 1.0.2) libdbus-glib-1-2 (2 0.78 ) libfontconfig1 (2 2.8.0) libfreetype6 (2 2.3.9) libgcc1 (2 1:4.1.1) libgdk-pixbuf2.0-0 (2 2.22.0) libglib2.0-0 (2 2.31.8 ) libgtk2.0-0 (2 2.24.0) libpango1.0-0 (2 1.14.0) libstartup-notification0 (2 0.8 ) libstdc++6 (2 4.6) libx11-6 (0 (null)) libxext6 (0 (null)) libxrender1 (0 (null)) libxt6 (0 (null)) latex-xft-fonts (0 (null)) libthai0 (0 (null)) firefox-gnome-support (0 (null)) xul-ext-ubufox (0 (null)) firefox-globalmenu (0 (null)) libcanberra0 (0 (null)) gcu-plugin (1 0.12.10-1ubuntu1) abrowser (1 4.0~b11+build3+nobinonly-0ubuntu1) abrowser-branding (1 4.0~b11+build3+nobinonly-0ubuntu1) adobe-flashplugin (1 11.1.102.63-0precise1) firefox-branding (1 4.0~b11+build3+nobinonly-0ubuntu1) flashplugin-installer (1 11.1.102.63ubuntu1) abrowser (0 (null)) abrowser-branding (0 (null)) firefox-branding (0 (null)) kubuntu-firefox-installer (0 (null))
11.0+build1-0ubuntu4 - lsb-release (0 (null)) libasound2 (2 1.0.23) libatk1.0-0 (2 1.12.4) libc6 (2 2.15) libcairo2 (2 1.2.4) libdbus-1-3 (2 1.0.2) libdbus-glib-1-2 (2 0.78 ) libfontconfig1 (2 2.8.0) libfreetype6 (2 2.2.1) libgcc1 (2 1:4.1.1) libgdk-pixbuf2.0-0 (2 2.22.0) libglib2.0-0 (2 2.31.8 ) libgtk2.0-0 (2 2.24.0) libpango1.0-0 (2 1.14.0) libstartup-notification0 (2 0.8 ) libstdc++6 (2 4.6) libx11-6 (0 (null)) libxext6 (0 (null)) libxrender1 (0 (null)) libxt6 (0 (null)) latex-xft-fonts (0 (null)) libthai0 (0 (null)) firefox-gnome-support (16 (null)) firefox-kde-support (0 (null)) xul-ext-ubufox (0 (null)) firefox-globalmenu (0 (null)) gcu-plugin (1 0.12.10-1ubuntu1) abrowser (1 4.0~b11+build3+nobinonly-0ubuntu1) abrowser-branding (1 4.0~b11+build3+nobinonly-0ubuntu1) adobe-flashplugin (1 11.1.102.63-0precise1) firefox-branding (1 4.0~b11+build3+nobinonly-0ubuntu1) flashplugin-installer (1 11.1.102.63ubuntu1) abrowser (0 (null)) abrowser-branding (0 (null)) firefox-branding (0 (null)) kubuntu-firefox-installer (0 (null))
Provides:
16.0+build1-0ubuntu0.12.04.1 - www-browser iceweasel gnome-www-browser
15.0.1+build1-0ubuntu0.12.04.1 - www-browser iceweasel gnome-www-browser
11.0+build1-0ubuntu4 - www-browser iceweasel gnome-www-browser
Reverse Provides:


Det er Versions afsnittet vi er interesseret i, og der er følgende versioner til rådighed:
  • 16.0+build1-0ubuntu0.12.04.1 - det er den nye med sikkerhedshullet i
  • 15.0.1+build1-0ubuntu0.12.04.1 - den som Mozilla Foundation anbefaler at man nedgraderer til/beholder og lader være med at opgradere til 16.0
  • 11.0+build1-0ubuntu4 - rigtig gammel FF

Pakkenedgradering - How to

Du kører den her kommando for at nedgradere Firefox fra version 16.0+build1-0ubuntu0.12.04.1 til version 15.0.1+build1-0ubuntu0.12.04.

Kode: Vælg alt

sudo aptitude install firefox=15.0.1+build1-0ubuntu0.12.04.1

Bemærk at du måske lige skal installere aptitude først.

For de her pakker:
  • firefox-locale-da
  • firefox-locale-en
  • firefox
  • firefox-gnome-support
- incl andre Firefox sprogpakker du måtte have inde også
kan det være at måske skal afinstallere (remove) pakkerne dem først:

Kode: Vælg alt

sudo apt-get remove firefox-locale-en firefox-locale-da firefox-gnome-support firefox

Så hive version 15 versionnummeret ud med apt-cache (kig i versions: delen af output)
... og til sidst så installere hver af pakkerne med overstående aptitude install kommando - installer i den her rækkefølge: firefox, firefox-gnome-support, firefox-locale-da, firefox-locale-en

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
Jimmyfj
Indlæg: 1712
Tilmeldt: 19. jul 2007, 19:35
Geografisk sted: Nordjylland

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af Jimmyfj »

I stedet for den almindelige FF kan du jo også installere Firefox Nightly Build som er rock-solid. Følg denne vejledning:

http://ubuntuforums.org/showthread.php?t=1926024

Min Nightly er oppe i version 19.0a1(2012-10-10) og kører rent ud sagt fantastisk.
"OM 100 ÅR ER ALTING GLEMT !"


Ubuntu - Dev-ed.
Linux User # 448500
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af lath »

Jimmyfj skrev:I stedet for den almindelige FF kan du jo også installere Firefox Nightly Build som er rock-solid. Følg denne vejledning:

http://ubuntuforums.org/showthread.php?t=1926024

Min Nightly er oppe i version 19.0a1(2012-10-10) og kører rent ud sagt fantastisk.


Jeg har en politik der hedder ingen beta og især alfa versionssoftware på produktionsmaskiner.
(-og nej det er ikke en virksomhed, men min politik for software på produktionsmaskiner er som om det var en virksomhed)

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
AJenbo
Admin
Indlæg: 20861
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af AJenbo »

16.0.1 får du kun hvis du bruger samme ppa som han gør.
AJenbo
Admin
Indlæg: 20861
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af AJenbo »

Så er 16.0.1 blevet sendt til Ubuntu arkivet så det er bare at opdatere og så skulle alt være godt.
Brugeravatar
Kurt Christensen
Indlæg: 2246
Tilmeldt: 12. feb 2011, 13:22
IRC nickname: How to be me

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af Kurt Christensen »

hvis man ikke bruger Firefox og men Chrome og bare har den liggende på maskinen, bliver problemet så ikke løst automatisk ved opdateringer?
Når lejligheden byder sig.
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af lath »

AJenbo skrev:Så er 16.0.1 blevet sendt til Ubuntu arkivet så det er bare at opdatere og så skulle alt være godt.


Takker, har lige låst Firefox pakkerne op fra version 15.0.1 og er i gang med at installere 16.0.1 samt de andre 10 pakker - det meste vedrører en ny kerne.

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af lath »

How to be me skrev:hvis man ikke bruger Firefox og men Chrome og bare har den liggende på maskinen, bliver problemet så ikke løst automatisk ved opdateringer?


Jo, til 12.04.1 er den er ude nu sammen med en ny kerne.

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
Brugeravatar
Kurt Christensen
Indlæg: 2246
Tilmeldt: 12. feb 2011, 13:22
IRC nickname: How to be me

Re: SIKKERHEDSHUL i Firefox 16 | NEDGRADÉR TIL Firefox 15 -

Indlæg af Kurt Christensen »

jeg har lige opdateret, så jeg antager problemet er løst.
Når lejligheden byder sig.