problemer med tilgang til softlink paa localhost

Få hjælp og support til alt server-relateret. Guides og How-to's i forbindelse med servere hører også til her.
Charlot
Indlæg: 2
Tilmeldt: 21. maj 2015, 13:53

problemer med tilgang til softlink paa localhost

Indlægaf Charlot » 21. maj 2015, 14:18

Hej!

Jeg har installeret min lamp-server - det gik fint!
Lavede et softlink til min mappe med hele hjemmesiden: php, js... - det gik fint!
Saa installerede jeg phpmyadmin - det gik fint!
Importerede databasen - det gik ogsaa fint!
Jeg var blevet advaret om sikkerhedsproblemer med phpmyadmin, saa jeg fulgte denne guide for at sikre mig: https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-on-ubuntu-14-04

Nu kommer problemet - jeg har rigtignok sikret min database med kodeord og brugernavn. Til gengaeld virker mit softlink ikke laengere. Jeg har efterhaanden brugt nogle timer paa diverse fora, Stackoverflow etc, uden at komme en loesning naemere - har andre herinde haft samme problem? Naar jeg kigger i apache2's errorlog finder jeg dette: "Symbolic link not allowed or link target not accessible: /var/www/html/c5". Det maa vaere mine sikkerhedsindstillinger, der er for snaevre, men jeg har ikke indsigt nok i, hvordan serveren virker, for at komme videre. Alle bud paa en loesning er velkomne!

(og mens vi er ved - kan nogen hurtigt give mig et link, der forklarer mig, hvordan jeg faar danske bogstaver med genvejstaster paa dette tastatur? Det er absolut ikke obligatorisk, jeg finder det nok selv, hvis jeg leder laenge nok ... )

Charlot
Indlæg: 2
Tilmeldt: 21. maj 2015, 13:53

Re: problemer med tilgang til softlink paa localhost

Indlægaf Charlot » 21. maj 2015, 14:32

Hey- Så fik jeg løst mit bogstavproblem!

AJenbo
Admin
Indlæg: 19121
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: problemer med tilgang til softlink paa localhost

Indlægaf AJenbo » 21. maj 2015, 15:39

Hej og velkommen til formmet

Frem for at lave et symbolsk link så ændre mappen hvor apache læser siden fra:

Kode: Vælg alt

sudo nano /etc/apache2/sites-available/000-default.conf


Her skal du ændre DocumentRoot til din sti.

Du bør også tilføje følgende for at serveren må servere filer fra mappen:

Kode: Vælg alt

<Directory /home/charlot/dinside>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
        Order allow,deny
        allow from all
</Directory>


Sidst bør du også tjekke at www-data brugeren må læse filerne i den pågældende mappe, som standard har alle dog lov til at læse filer fra din mappe så det burde ikke være det store problem.

Tilbage til "Server: Guides, installation og opsætning"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster