opsætning af server ? fejl Emnet er løst

Få hjælp og support til alt server-relateret. Guides og How-to's i forbindelse med servere hører også til her.
dgaa1991
Indlæg: 187
Tilmeldt: 5. aug 2010, 21:53
IRC nickname: dgaa1991
Geografisk sted: København SV

Re: opsætning af server ? fejl

Indlægaf dgaa1991 » 9. okt 2014, 00:05

martin joergensen skrev:Jeg overlever sq nok ;:)

I kan stadig bruge kupon koden mener i får 10 US-Dollers, jeg har selv server på AMS2 og 3


Det virkede også fint for mig

thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: opsætning af server ? fejl

Indlægaf thj01 » 9. okt 2014, 10:24

@lath

Det er ikke forkert det der står i ubuntu's servermanual - der er bare en del ting de forudsætter at brugeren af den ved i forvejen. Det kan f.eks. være hvordan konfigurerer tjenesterne sådan at de er praktisk anvendelige i forskellige setups.

F.eks. hvordan man får LAMP og især PHP til at spille sammen med brugere der har deres webmappe i ~/public_html. Det har intet med LAMP serveren at gøre for den fungere fint med /var/www. Det er en PHP indstilling man skal vide hvor man skal ændre den ;). Og man skal anvende de rigtige søgeord i Google for ellers finder man ikke løsningen (jeg brugte ihvertfald en del frustrations tid på det ;)

Eller hvordan man får en Ubuntu klient til at anvende serverens DHCP indstillinger (læs nedprioritere Ubuntu-klientens egen simple DNS tjeneste)

Jeg har ikke tjekket Debians manualer, men jeg kunne forestille mig at der også er en del "det ved man godt som administrator" i det

For lad os nu bare erkende det - servere er ikke for amatører ;).
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

dgaa1991
Indlæg: 187
Tilmeldt: 5. aug 2010, 21:53
IRC nickname: dgaa1991
Geografisk sted: København SV

Re: opsætning af server ? fejl

Indlægaf dgaa1991 » 9. okt 2014, 11:37

thj01 skrev:@lath

Det er ikke forkert det der står i ubuntu's servermanual - der er bare en del ting de forudsætter at brugeren af den ved i forvejen. Det kan f.eks. være hvordan konfigurerer tjenesterne sådan at de er praktisk anvendelige i forskellige setups.

F.eks. hvordan man får LAMP og især PHP til at spille sammen med brugere der har deres webmappe i ~/public_html. Det har intet med LAMP serveren at gøre for den fungere fint med /var/www. Det er en PHP indstilling man skal vide hvor man skal ændre den ;). Og man skal anvende de rigtige søgeord i Google for ellers finder man ikke løsningen (jeg brugte ihvertfald en del frustrations tid på det ;)

Eller hvordan man får en Ubuntu klient til at anvende serverens DHCP indstillinger (læs nedprioritere Ubuntu-klientens egen simple DNS tjeneste)

Jeg har ikke tjekket Debians manualer, men jeg kunne forestille mig at der også er en del "det ved man godt som administrator" i det

For lad os nu bare erkende det - servere er ikke for amatører ;).



damn.. jeg er sq nok på stadiet amatør :S i am gonna proove you are wrong :D

thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: opsætning af server ? fejl

Indlægaf thj01 » 9. okt 2014, 14:23

Kun en tåbe frygter ikke opsætning af servere gg.
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

dgaa1991
Indlæg: 187
Tilmeldt: 5. aug 2010, 21:53
IRC nickname: dgaa1991
Geografisk sted: København SV

Re: opsætning af server ? fejl

Indlægaf dgaa1991 » 12. okt 2014, 00:37

nåå. skæbnen ville at min server ikke kom før weekenden men har siddet og lejet lidt og må jo erkende at alt har en begyndelse jeg er kommet lidt i tvivl om følgende :

det hele er startet på en ny installation af ubuntu 14.04 server edition og de teneste jeg har installeret indtil videre er SSH

hvad skal jeg indtaste under /etc/network/interfaces og så under

Kode: Vælg alt

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.2.149
        netmask 255.255.255.0
        network 192.168.2.149
        broadcast 192.1681.255
        gateway 192.168.1.1
        dns-nameservers 192.168.1.200 192.168.1.225 8.8.8.8 


jeg har ændret det hele i troen om det er rigtigt :D undtagen dns-nameserver der stod jeg af engang



og så er der ved pakke lsiten jeg skal enable et eller andet og jeg kan ikke helt finde ud af hvordan jeg gør det..
det er på side 3 punkt 8.

http://www.howtoforge.com/perfect-server-ubuntu-14.04-apache2-php-mysql-pureftpd-bind-dovecot-ispconfig-3-p3

min ifconfig ser således ud

Kode: Vælg alt

daniel@owncloud:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 08:00:27:7a:df:33 
          inet addr:192.168.1.149  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe7a:df33/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:130 errors:0 dropped:0 overruns:0 frame:0
          TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21299 (21.2 KB)  TX bytes:14595 (14.5 KB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1184 (1.1 KB)  TX bytes:1184 (1.1 KB)


jeg siger på forhånd tak hvis der er nogen der har tålmodigheden til at hjælpe mig endnu engang

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: opsætning af server ? fejl

Indlægaf AJenbo » 12. okt 2014, 02:38

Kørte du ifconfig inden du begynde at rode med netværks opsætningen? Ellers så sæt den lige tilbage til standard, sikre dig at den kan komme på nettet og kør ifconfig der.

Jeg bryder mig ikke om den guide du har fundet da noget af det første den gør er at aktivere root brugeren hvilket er no no. Jeg syndes også den gør mere end blot at sætte en fast ip og gør ikke rigtig rede for hvad der ændres eller hvorfor.

Hvad er det du prøver at opnå?

dgaa1991
Indlæg: 187
Tilmeldt: 5. aug 2010, 21:53
IRC nickname: dgaa1991
Geografisk sted: København SV

Re: opsætning af server ? fejl

Indlægaf dgaa1991 » 12. okt 2014, 09:13

AJenbo skrev:Kørte du ifconfig inden du begynde at rode med netværks opsætningen? Ellers så sæt den lige tilbage til standard, sikre dig at den kan komme på nettet og kør ifconfig der.

Jeg bryder mig ikke om den guide du har fundet da noget af det første den gør er at aktivere root brugeren hvilket er no no. Jeg syndes også den gør mere end blot at sætte en fast ip og gør ikke rigtig rede for hvad der ændres eller hvorfor.

Hvad er det du prøver at opnå?


ifconfig er kørt inden jeg rodede med opsætningen som jeg heller ikke har gjort endnu den er kun skrevet om her inde.
men jeg er heller ikke helt sikker på den guide der da der er ting som SKAL installeres som jeg ikke helt enig med at de burde for at kunne køre owncloud. Det skal siges indtil videre har jeg kun kørt med sudo og ikke suso su

det jeg prøver på er at sætte en server op som skal hoste owncloud som jeg gerne skulle kunne tilegne mig adgang til uden at skulle være på et lokalt netværk.
Jeg har fået tildelt en publiv ip fra min internetudbydder nu. og jeg er kommet frem til at en lamp server med phpmyadmin og efterfølgende owncloud burde kunne gøre det. og så er jeg ikke ikke helt sikker på hvorvidt jeg skal sætte en mail server op også for at sende mails om lost password og fileshare fra owncloud

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: opsætning af server ? fejl  Emnet er løst

Indlægaf AJenbo » 12. okt 2014, 11:36

Det skulle kun være nødvendigt at sætte postfix op så sendmail kan sende mail, det er ikke nødvendig med en hel mail server opsætning.

En anden løsning mht. ip opsætningen kunne også være at sætte det op i din router så den altid tildeler den samme IP til det netkort.

Der er kommandoer i guiden der er skrevet på en måde så de ikke ville fungere hvis man blot bruger sudo, det er så lidt uheldigt at den starter med at skrive at man kan. "sudo su" er ikke helt så slem da den ikke efterlader et hul i dit system men blot gør at du kan komme til at gøde lægge noget mens du køre som root. Der er visse handlinger der kun kan gøres via "sudo su".

følgende:

Kode: Vælg alt

echo server1.example.com > /etc/hostname


skal i stedet være for at fungere med sudo:
Rediger /etc/hostname så den ser ud som for neden

Kode: Vælg alt

sudo nano /etc/hostname

server1.example.com


Jeg syndes du skal springe punkt 6, 9 og 10 over.

Punkt 8 ville både fungere bedre og være tilstrækkelig med blot:

Kode: Vælg alt

sudo aptitude safe-upgrade; sudo reboot

Ellers opdatere den ikke kernen.

thj01
Indlæg: 2667
Tilmeldt: 21. nov 2006, 10:06
Geografisk sted: Fredericia

Re: opsætning af server ? fejl

Indlægaf thj01 » 12. okt 2014, 22:20

Hvorfor er sudo SU et no go?
Forfatter til Ubuntuguiden: http://www.vidas.dk/guides/ubuntuguiden.html

Kører LTS udgaverne.

"It's always easy if you know how to do it."

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: opsætning af server ? fejl

Indlægaf AJenbo » 13. okt 2014, 00:05

Det er aktivering af root der er "no NO". "sudo su" vil jeg dog også fra råde i det omfang det er muligt da det efterlader en i en tilstand hvor man kan komme til at skade systemet og det ikke er tydeligt ud fra logs hvem det er der laver ændringer på systemet.

dgaa1991
Indlæg: 187
Tilmeldt: 5. aug 2010, 21:53
IRC nickname: dgaa1991
Geografisk sted: København SV

Re: opsætning af server ? fejl

Indlægaf dgaa1991 » 21. okt 2014, 23:02

nå min maskine der skulle køre min server er desværre i stykker så indtil videre har jeg bare leget lidt i Virtualbox. men jeg siger tak for hjælpen alle sammen! det ha rnu lykkedes med at lave en lamp server med owncloud som faktisk fungere uden for det lokale netværk ! ;) næste skridt er nu at køre ubuntu server med vm og så evt køre owncloud på en lemp stack istedet for lamp da det skulle være en noget bedre performance man får ud af dette

martin joergensen
Indlæg: 293
Tilmeldt: 12. maj 2014, 18:29
Geografisk sted: Kolding

Re: opsætning af server ? fejl

Indlægaf martin joergensen » 22. okt 2014, 07:43

Jeg bruger kun nginx fremfor apache

dgaa1991
Indlæg: 187
Tilmeldt: 5. aug 2010, 21:53
IRC nickname: dgaa1991
Geografisk sted: København SV

Re: opsætning af server ? fejl

Indlægaf dgaa1991 » 22. okt 2014, 09:50

Nginx skulle også være det bedre i forhold til performance i forhold til apache2 men det skulle også være lidt mere indviklet så jeg ved ikke helt om jeg er klar til at begi mig ud i det endnu

lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: opsætning af server ? fejl

Indlægaf lath » 22. okt 2014, 10:03

martin joergensen skrev:Jeg bruger kun nginx fremfor apache

Jeg vil også bruge en letvægtsserver som nginx.

Jeg tænker på at bruge nginx til at servere filer (ressourcer), samt at være en reverse proxy for 1 application server af DIY typen.

Det bliver på en Digital Ocean droplet, men jeg skifter muligvis nok til en FreeBSD 10 VPS på vultr.com

DNS for mit domæne styrer jeg via gratisdns.dk - og ja, det er gratis. :)

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: opsætning af server ? fejl

Indlægaf AJenbo » 22. okt 2014, 11:48

På nogle punkter er nginx mindst lige så let som apache, men så støder man ind i problemer hvor nedarvning af reglerne ikke virker og så vokser ens configurationsfil til det double

Tilbage til "Server: Guides, installation og opsætning"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster