LibreOffice lukker uventet Emnet er løst

Alle tekniske spørgsmål som ikke hører ind under de andre fora.
pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

LibreOffice lukker uventet

Indlægaf pelle » 29. jun 2017, 13:37

LibreOffice 5 WRITER vil ikke åbne. Den viser i et glimt LibreOffice 5 (Plakaten)
Derefter sker der intet, heller ikke hvis jeg kalder med en fil *.odt
Calc og de andre virker fint.

Har prøvet at geninstallere. sudo apt-get update; sudo apt-get install libreoffice
Det gør den OK, men WRITER virker stadig ikke.

Hjælp.
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet

Indlægaf AJenbo » 29. jun 2017, 14:29

Prøv at starte det fra terminalen og se om der kommer en fejlbesked:

Kode: Vælg alt

lowriter

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 29. jun 2017, 14:37

Det ser sådan ud:

lowriter ** (process:2921): WARNING **: require a newer gtk than 3.10 for theme expectations
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet

Indlægaf AJenbo » 29. jun 2017, 15:02

Kode: Vælg alt

lowriter --version

Kode: Vælg alt

dpkg -s libgtk-3-0|grep '^Version'


Har du opgraderet LIbraOffice fra en uofficel kilde?

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 29. jun 2017, 15:24

pelle@pelle-Latitude-D520:~$ lowriter --version
LibreOffice 5.3.3.2 30m0(Build:2)

pelle@pelle-Latitude-D520:~$ dpkg -s libgtk-3-0|grep '^Version'
Version: 3.10.8-0ubuntu1.6

Har ikke opdateret LibreOffice fra anden kilde.
Bruger Ubuntu 14.04 opdateret i går 28.06.2017
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet

Indlægaf AJenbo » 29. jun 2017, 15:33

Den officelle version af LibreOffice til Ubuntu 14.04 er 5.1 så hvis du har 5.3.3.2 (selv i Ubuntu 17.04 er det stadig kun version 5.3.1.2) må du have installeret den ude fra. Problemet er nok at den seneste udgave der fra ikke er tilpasset den efterhånden noget aldrene 14.04.

Prøv at opgradere til Ubuntu 16.04, den kommer med GTK 3.18 så der er bedre chance for at det virker der. Standard udgaven af LibreOffice i 16.04 er desuden 5.1.6.

Opdateret:
Jeg kan se du tidligere nettop har haft problemer med en uofficel udgave af LibreOffice på dit system.
viewtopic.php?f=4&t=21460&p=152627#p152627

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 29. jun 2017, 15:44

Jeg er desværre nødt til at beholde 14.04 af hensyn til andre programmer og hardware.

Hvad gør jeg så?
Denne PC er ret vigtig for mig.

Klip det venligst ud i PAP. Jeg fylder 78 år i næste måned!

Jeg har mine data på en USB-pind, men hvis jeg blot benytter en anden PC (14.04), så
går det godt, MEN mine dokumenter kan så ikke redigeres: SKRIVEBESKYTTET.
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet

Indlægaf AJenbo » 29. jun 2017, 16:01

Prøv at kopiere dokumentet til maskinen og se om det så stadig er skrivebeskyttet, hvis det er det må du kigge på hvilke rettigheder/filsystem du har sat på din USB.

Du kan fjerne den uofficelle udgave af libreoffice så du køre med den officelle 5.1. Du kan også prøve Snap udgaven som jeg beskrev i din forrige tråd om emnet.

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 29. jun 2017, 22:17

Hvor finder jeg LibreOffice WRITER ver 5.1??
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet  Emnet er løst

Indlægaf AJenbo » 30. jun 2017, 00:05

Du får det ved at fjerne den version du har installeret.

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 30. jun 2017, 09:21

Hvordan fjerner jeg ALT fra ver 5.3.3.2 ?

Hvordan får jeg derefter ver 5.1 ?

lige nu er jeg kørt fast. Taknemmelig for hjælp.
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet

Indlægaf AJenbo » 30. jun 2017, 16:44

Hvis dit system er som fra sidste gang så prøv:

Kode: Vælg alt

sudo apt install ppa-purge
ppa-purge ppa:libreoffice/ppa

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 30. jun 2017, 18:11

Jeg får følgende
pelle@pelle-Latitude-D520:~$ sudo apt install ppa-purge
[sudo] password for pelle:
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Nogle pakker kunne ikke installeres. Det kan betyde at du har ønsket
en umulig situation eller bruger den ustabile distribution, hvor enkelte
pakker endnu ikke er lavet eller gjort tilgængelige.
Følgende oplysninger kan hjælpe dig med at klare situationen:

Følgende pakker har uopfyldte afhængigheder:
ppa-purge : Afhængigheder: aptitude (>= 0.6.6-1ubuntu1.2) men den kan ikke installeres
E: Kunne ikke korrigere problemerne, da du har tilbageholdt ødelagte pakker.
pelle@pelle-Latitude-D520:~$ ppa-purge ppa:libreoffice/ppa
Programmet "ppa-purge" er ikke installeret lige nu. Du kan installere det ved at taste:
sudo apt-get install ppa-purge
pelle@pelle-Latitude-D520:~$ sudo apt-get install ppa-purge
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Nogle pakker kunne ikke installeres. Det kan betyde at du har ønsket
en umulig situation eller bruger den ustabile distribution, hvor enkelte
pakker endnu ikke er lavet eller gjort tilgængelige.
Følgende oplysninger kan hjælpe dig med at klare situationen:

Følgende pakker har uopfyldte afhængigheder:
ppa-purge : Afhængigheder: aptitude (>= 0.6.6-1ubuntu1.2) men den kan ikke installeres
E: Kunne ikke korrigere problemerne, da du har tilbageholdt ødelagte pakker.
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

AJenbo
Admin
Indlæg: 20491
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: LibreOffice lukker uventet

Indlægaf AJenbo » 30. jun 2017, 18:34

Du har stadig/igen problemer med pakke arkivet på din maskine. Så du kan ikke installere, opdatere eller fjerne programmer. Prøv første denne kommando:

Kode: Vælg alt

sudo apt-get install -f

pelle
Indlæg: 117
Tilmeldt: 14. feb 2008, 18:19
Geografisk sted: Spanien

Re: LibreOffice lukker uventet

Indlægaf pelle » 30. jun 2017, 19:02

pelle@pelle-Latitude-D520:~$ sudo apt-get install -f
[sudo] password for pelle:
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 0 opgraderes ikke.
pelle@pelle-Latitude-D520:~$ sudo apt install ppa-purge
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Nogle pakker kunne ikke installeres. Det kan betyde at du har ønsket
en umulig situation eller bruger den ustabile distribution, hvor enkelte
pakker endnu ikke er lavet eller gjort tilgængelige.
Følgende oplysninger kan hjælpe dig med at klare situationen:

Følgende pakker har uopfyldte afhængigheder:
ppa-purge : Afhængigheder: aptitude (>= 0.6.6-1ubuntu1.2) men den kan ikke installeres
E: Kunne ikke korrigere problemerne, da du har tilbageholdt ødelagte pakker.
pelle@pelle-Latitude-D520:~$ ppa-purge ppa:libreoffice/ppa
Programmet "ppa-purge" er ikke installeret lige nu. Du kan installere det ved at taste:
sudo apt-get install ppa-purge
pelle@pelle-Latitude-D520:~$ apt-get install ppa-purge
E: Kunne ikke åbne låsefilen /var/lib/dpkg/lock - open (13: Adgang nægtet)
E: Kunne ikke låse administrationsmappen (/var/lib/dpkg/), er du rod (root)?
pelle@pelle-Latitude-D520:~$ sudo apt-get install ppa-purge
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Nogle pakker kunne ikke installeres. Det kan betyde at du har ønsket
en umulig situation eller bruger den ustabile distribution, hvor enkelte
pakker endnu ikke er lavet eller gjort tilgængelige.
Følgende oplysninger kan hjælpe dig med at klare situationen:

Følgende pakker har uopfyldte afhængigheder:
ppa-purge : Afhængigheder: aptitude (>= 0.6.6-1ubuntu1.2) men den kan ikke installeres
E: Kunne ikke korrigere problemerne, da du har tilbageholdt ødelagte pakker.
pelle@pelle-Latitude-D520:~$
UBUNTU 18.04 (64-bit)
DELL Latitude E5540: intel core i5-4300U CPU @ 1.90GHz x 4
Grafik: Intel Haswell Mobile

Tilbage til "Tekniske spørgsmål generelt"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster