Java eller flash problemer

Har du spørgsmål til andre systemer end Ubuntu kan du stille dem her.
kent a
Indlæg: 695
Tilmeldt: 31. dec 2009, 10:07
Geografisk sted: Erslev på Mors

Java eller flash problemer

Indlægaf kent a » 7. dec 2011, 20:31

Hej..

Jeg er løbet et i et eller andent problem med nogle spil på stavevejen.dk..

Men det mest underlig af det hele er at youtube, kom og vind, nemid. virker helt uden problemer...

jeg møder sådan en skærm.

javapro.png
javapro.png (111.55 KiB) Vist 621 gange


Siden kilde oplæysninger er følgene.

<html>
<head>
<title>Stavevejen 2</title>
<script language="JavaScript">
<!--
if (document.all) {
document.write("<link rel='STYLESHEET' type='text/css' href='../css/stave4e.css'>")
}
else{
document.write("<link rel='STYLESHEET' type='text/css' href='../css/stave4n.css'>")
}
//-->
</script>

<script language="JavaScript">
function openWin(parameter) {
//window.open("test.html", "upload", "height=150,width=400");
var help_win = window.open("../uploadpussel.asp?userid=658145", 'hlab', 'width=300,height=150,screenX=20,screenY=20,top=20,left=20');
// alert(parameter);
}
</script>

<script language="vbscript">
sub MovieName_ExternalEvent(byVal aCommand)
call openWin(aCommand)
end sub
</script>

</head>

<body background="../image/layout/bgr.jpg" topmargin="0" leftmargin="0" marginheight="0" marginwidth="0">





<object classid="clsid:166B1BCA-3F9C-11CF-8075-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/director/sw.cab#version=10,0,0,0&quot;
ID=TOGETmx width=100% height=100%>

<PARAM NAME="sw1" VALUE="658145">
<PARAM NAME="sw2" VALUE="1"><PARAM NAME="SRC" VALUE="../shockwave/Hangebroen.dcr">
<PARAM NAME="sw3" VALUE="69739">
<PARAM NAME="sw4" VALUE="www.stavevejen.dk/stave02">
<PARAM NAME="sw5" VALUE="304900">
<PARAM NAME="sw6" VALUE="Kim Andersen - VUCKursist">

<PARAM NAME="sw7" VALUE="student#exercise_f.asp?pic=broen.JPG#exercise">
<PARAM NAME="sw70" VALUE="">

<param name=swRemote value="swSaveEnabled='true' swVolume='true' swRestart='true' swPausePlay='true' swFastForward='true' swContextMenu='true' ">
<param name=swStretchStyle value=meet>
<PARAM NAME=bgColor VALUE=#000000> <PARAM NAME=swStretchHAlign VALUE=Center> <PARAM NAME=swStretchVAlign VALUE=Center>
<embed src="../shockwave/Hangebroen.dcr" sw1="658145" sw2="1" sw3="69739" sw4="www.stavevejen.dk/stave02" sw5="304900" sw6="Kim Andersen - VUCKursist" sw7="student#exercise_f.asp?pic=broen.JPG#exercise" sw70="" bgColor=#000000 swStretchHAlign=Center swStretchVAlign=Center width=100% height=100% swRemote="swSaveEnabled='true' swVolume='true' swRestart='true' swPausePlay='true' swFastForward='true' swContextMenu='true' " swStretchStyle=meet
type="application/x-director" pluginspage="http://www.macromedia.com/shockwave/download/"></embed&gt;
</object>





</body>
</html>
Lubuntu 18.04 LTS

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Java eller flash problemer

Indlægaf Stra » 7. dec 2011, 22:18

Jeg vil hellere se, hvad denne linie, som skrives i adressefeltet i firefox, siger : about:plugins
stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

AJenbo
Admin
Indlæg: 20599
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Java eller flash problemer

Indlægaf AJenbo » 8. dec 2011, 18:43

Det er ikke Flash eller Java men ShockWave. Der findes ikke en ShockWave klient, men måske er det muligt at køre det via Wine.

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: Java eller flash problemer

Indlægaf laoshi » 8. dec 2011, 19:35

Men shockwave skulle kunne køres med flashplayeren. Jeg vil foreslå at du prøver at køre den lange flash-genopretnings-kommando:

Kode: Vælg alt

sudo apt-get remove -y --purge flashplugin-installer flashplugin-nonfree gnash gnash-common libflashsupport mozilla-plugin-gnash nspluginwrapper swfdec-mozilla adobe-flashplugin && sudo rm -f /usr/lib/mozilla/plugins/*flash* ~/.mozilla/plugins/*flash*so /usr/lib/firefox-addons/plugins/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so ~/.wine/dosdevices/c:/windows/system32/Macromed/Flash /usr/lib/chromium-browser/plugins/libflashplayer.so /usr/lib/flashplugin-installer/libflashplayer.so /usr/share/ubufox/plugins/libflashplayer.so && sudo dpkg -r --force-remove-reinstreq flashplugin-nonfree && sudo apt-get install -y flashplugin-installer flashplugin-nonfree && sudo ln -s /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/firefox-addons/plugins/libflashplayer.so && sudo apt-get autoremove -y --force-yes && sudo apt-get update -y && sudo apt-get upgrade -y

(fra christian.arvais faq)
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

AJenbo
Admin
Indlæg: 20599
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Java eller flash problemer

Indlægaf AJenbo » 8. dec 2011, 19:46

laoshi skrev:Men shockwave skulle kunne køres med flashplayeren

Nej.

kent a
Indlæg: 695
Tilmeldt: 31. dec 2009, 10:07
Geografisk sted: Erslev på Mors

Re: Java eller flash problemer

Indlægaf kent a » 8. dec 2011, 20:11

Stra skrev:Jeg vil hellere se, hvad denne linie, som skrives i adressefeltet i firefox, siger : about:plugins



Aktiverede plugins
Læs mere information om browser-plugins på mozilla.org.
Find opdateringer til installerede plugins på mozilla.com/plugincheck.
Hjælp til at installere plugins er tilgænglig fra plugindoc.mozdev.org.
Gnome Shell Integration

Fil: libgnome-shell-browser-plugin.so
Version:
This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org

MIME Type Beskrivelse Endelser
application/x-gnome-shell-integration Gnome Shell Integration Dummy Content-Type
mplayerplug-in is now gecko-mediaplayer 1.0.4

Fil: gecko-mediaplayer.so
Version:
Gecko Media Player 1.0.4

Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

MIME Type Beskrivelse Endelser
audio/x-mpegurl MPEG Playlist m3u
video/mpeg MPEG mpg,mpeg
audio/mpeg MPEG mpg,mpeg
video/x-mpeg MPEG mpg,mpeg
video/x-mpeg2 MPEG2 mpv2,mp2ve
audio/mpeg MPEG mpg,mpeg
audio/x-mpeg MPEG mpg,mpeg
audio/mpeg2 MPEG audio mp2
audio/x-mpeg2 MPEG audio mp2
audio/mp4 MPEG 4 audio mp4
audio/x-mp4 MPEG 4 audio mp4
video/mp4 MPEG 4 Video mp4
video/x-m4v MPEG 4 Video m4v
video/3gpp MPEG 4 Video mp4,3gp
audio/mpeg3 MPEG audio mp3
audio/x-mpeg3 MPEG audio mp3
audio/x-mpegurl MPEG url m3u
audio/mp3 MPEG audio mp3
application/x-ogg Ogg Vorbis Media ogg,oga,ogm
application/ogg Ogg Vorbis Media ogg,oga,ogm
audio/x-ogg Ogg Vorbis Audio ogg,oga
audio/ogg Ogg Vorbis Audio ogg,oga
video/x-ogg Ogg Vorbis Video ogg,ogm
video/ogg Ogg Vorbis Video ogg,ogm
application/x-vlc-plugin VLC plug-in vlc
application/x-google-vlc-plugin Google VLC plug-in
audio/flac FLAC Audio flac
audio/x-flac FLAC Audio flac
video/fli FLI animation fli,flc
video/x-fli FLI animation fli,flc
video/x-flv Flash Video flv
video/flv Flash Video flv
video/vnd.vivo VivoActive viv,vivo
audio/x-matroska Matroska Audio mka
video/x-matroska Matroska Video mkv
application/x-nsv-vp3-mp3 Nullsoft Streaming Video nsv
audio/x-mod Soundtracker mod
audio/x-aiff AIFF Audio aif
audio/basic Basic Audio File au,snd
audio/x-basic Basic Audio File au,snd
audio/x-scpls Shoutcast Playlist pls
video/x-mng Multiple-Image Network Graphics mng
audio/webm WEBM audio File webm
audio/x-webm WEBM audio File webm
video/webm WEBM video File webm
video/x-webm WEBM video File webm
Windows Media Player Plug-in

Fil: gecko-mediaplayer-wmp.so
Version:
Gecko Media Player 1.0.4

Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

MIME Type Beskrivelse Endelser
application/asx Media Files *
video/x-ms-asf-plugin Media Files *
video/x-msvideo AVI avi,*
video/msvideo AVI avi,*
application/x-mplayer2 Media Files *
video/x-mplayer2 Media Files *
application/x-ms-wmv Microsoft WMV video wmv,*
video/x-ms-asf Media Files asf,asx,*
video/x-ms-asx Media Files asx,*
video/x-ms-wm Media Files wm,*
video/x-ms-wmv Microsoft WMV video wmv,*
audio/x-ms-wmv Windows Media wmv,*
video/x-ms-wmp Windows Media wmp,*
application/x-ms-wmp Windows Media wmp,*
video/x-ms-wvx Windows Media wvx,*
audio/x-ms-wax Windows Media wax,*
audio/x-ms-wma Windows Media wma,*
application/x-drm-v2 Windows Media asx,*
audio/wav Microsoft wave file wav,*
audio/x-wav Microsoft wave file wav,*
DivX Browser Plug-In

Fil: gecko-mediaplayer-dvx.so
Version:
Gecko Media Player 1.0.4

Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

MIME Type Beskrivelse Endelser
video/divx DivX Media Format divx
video/vnd.divx DivX Media Format divx
RealPlayer 9

Fil: gecko-mediaplayer-rm.so
Version:
Gecko Media Player 1.0.4

Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

MIME Type Beskrivelse Endelser
audio/x-pn-realaudio RealAudio ram,rm
application/vnd.rn-realmedia RealMedia rm
application/vnd.rn-realaudio RealAudio ra,ram
video/vnd.rn-realvideo RealVideo rv
audio/x-realaudio RealAudio ra
audio/x-pn-realaudio-plugin RealAudio rpm
application/smil SMIL smil
QuickTime Plug-in 7.6.9

Fil: gecko-mediaplayer-qt.so
Version:
Gecko Media Player 1.0.4

Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

MIME Type Beskrivelse Endelser
video/quicktime Quicktime mov
video/x-quicktime Quicktime mov
image/x-quicktime Quicktime mov
video/quicktime Quicktime mp4
video/quicktime Quicktime - Session Description Protocol sdp
application/x-quicktimeplayer Quicktime mov
Java(TM) Plug-in 1.6.0_26

Fil: libnpjp2.so
Version:
The next generation Java plug-in for Mozilla browsers.

MIME Type Beskrivelse Endelser
application/x-java-vm Java™ Plug-in
application/x-java-applet Java™ Plug-in Applet
application/x-java-applet;version=1.1 Java™ Plug-in
application/x-java-applet;version=1.1.1 Java™ Plug-in
application/x-java-applet;version=1.1.2 Java™ Plug-in
application/x-java-applet;version=1.1.3 Java™ Plug-in
application/x-java-applet;version=1.2 Java™ Plug-in
application/x-java-applet;version=1.2.1 Java™ Plug-in
application/x-java-applet;version=1.2.2 Java™ Plug-in
application/x-java-applet;version=1.3 Java™ Plug-in
application/x-java-applet;version=1.3.1 Java™ Plug-in
application/x-java-applet;version=1.4 Java™ Plug-in
application/x-java-applet;version=1.4.1 Java™ Plug-in
application/x-java-applet;version=1.4.2 Java™ Plug-in
application/x-java-applet;version=1.5 Java™ Plug-in
application/x-java-applet;version=1.6 Java™ Plug-in
application/x-java-applet;jpi-version=1.6.0_26 Java™ Plug-in
application/x-java-bean Java™ Plug-in JavaBeans
application/x-java-bean;version=1.1 Java™ Plug-in
application/x-java-bean;version=1.1.1 Java™ Plug-in
application/x-java-bean;version=1.1.2 Java™ Plug-in
application/x-java-bean;version=1.1.3 Java™ Plug-in
application/x-java-bean;version=1.2 Java™ Plug-in
application/x-java-bean;version=1.2.1 Java™ Plug-in
application/x-java-bean;version=1.2.2 Java™ Plug-in
application/x-java-bean;version=1.3 Java™ Plug-in
application/x-java-bean;version=1.3.1 Java™ Plug-in
application/x-java-bean;version=1.4 Java™ Plug-in
application/x-java-bean;version=1.4.1 Java™ Plug-in
application/x-java-bean;version=1.4.2 Java™ Plug-in
application/x-java-bean;version=1.5 Java™ Plug-in
application/x-java-bean;version=1.6 Java™ Plug-in
application/x-java-bean;jpi-version=1.6.0_26 Java™ Plug-in
Lubuntu 18.04 LTS

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Java eller flash problemer

Indlægaf Stra » 8. dec 2011, 20:34

Prøv lige at køre den kode som lasohi anviser.

I min about:plugins har jeg flg.

Fil: libflashplayer.so
Version:
Shockwave Flash 11.1 r102

MIME Type Beskrivelse Endelser
application/x-shockwave-flash Shockwave Flash swf
application/futuresplash FutureSplash Player spl
stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

AJenbo
Admin
Indlæg: 20599
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Java eller flash problemer

Indlægaf AJenbo » 8. dec 2011, 20:43

Shockwave Flash og Shockwave er ikke det samme. http://get.adobe.com/shockwave/

Hvis der stadig er tviv:
http://en.wikipedia.org/wiki/Adobe_Shockwave_Player#Platform_support

Shockwave 10 ser ud til at køre fint under Wine og i følge siden du forsøger at besøge burde den være nok til at få det til at virke:
http://appdb.winehq.org/objectManager.php?sClass=version&iId=4682

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: Java eller flash problemer

Indlægaf laoshi » 8. dec 2011, 22:40

På det internationale forum er der en workaround for shockwave i 10.04 - måske virker det også i senere versioner.
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

kent a
Indlæg: 695
Tilmeldt: 31. dec 2009, 10:07
Geografisk sted: Erslev på Mors

Re: Java eller flash problemer

Indlægaf kent a » 9. dec 2011, 15:40

Stra skrev:Prøv lige at køre den kode som lasohi anviser.

I min about:plugins har jeg flg.

Fil: libflashplayer.so
Version:
Shockwave Flash 11.1 r102

MIME Type Beskrivelse Endelser
application/x-shockwave-flash Shockwave Flash swf
application/futuresplash FutureSplash Player spl



kent-lene@kentlene-E500-G-A234V ~ $ sudo apt-get remove -y --purge flashplugin-installer flashplugin-nonfree gnash gnash-common libflashsupport mozilla-plugin-gnash nspluginwrapper swfdec-mozilla adobe-flashplugin && sudo rm -f /usr/lib/mozilla/plugins/*flash* ~/.mozilla/plugins/*flash*so /usr/lib/firefox-addons/plugins/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so ~/.wine/dosdevices/c:/windows/system32/Macromed/Flash /usr/lib/chromium-browser/plugins/libflashplayer.so /usr/lib/flashplugin-installer/libflashplayer.so /usr/share/ubufox/plugins/libflashplayer.so && sudo dpkg -r --force-remove-reinstreq flashplugin-nonfree && sudo apt-get install -y flashplugin-installer flashplugin-nonfree && sudo ln -s /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/firefox-addons/plugins/libflashplayer.so && sudo apt-get autoremove -y --force-yes && sudo apt-get update -y && sudo apt-get upgrade -y
[sudo] password for kent-lene:
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Virtuelle pakker som 'flashplugin-nonfree' kan ikke fjernes
Virtuelle pakker som 'libflashsupport' kan ikke fjernes
Pakken gnash er ikke installeret, så den afinstalleres ikke
Pakken gnash-common er ikke installeret, så den afinstalleres ikke
Pakken mozilla-plugin-gnash er ikke installeret, så den afinstalleres ikke
Pakken swfdec-mozilla er ikke installeret, så den afinstalleres ikke
Pakken nspluginwrapper er ikke installeret, så den afinstalleres ikke
Pakken flashplugin-installer er ikke installeret, så den afinstalleres ikke
Pakken adobe-flashplugin er ikke installeret, så den afinstalleres ikke
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 7 opgraderes ikke.
dpkg: advarsel: there's no installed package matching flashplugin-nonfree
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Pakken flashplugin-nonfree er en virtuel pakke, der kan leveres af:
adobe-flashplugin 11.1.102.55-0oneiric1
flashplugin-downloader 11.1.102.55ubuntu0.11.10.1
Du bør eksplicit vælge en at installere.

E: Pakken 'flashplugin-nonfree' har ingen installationskandidat
Lubuntu 18.04 LTS

laoshi
Redaktør
Indlæg: 5515
Tilmeldt: 26. apr 2008, 20:52
IRC nickname: laoshi
Geografisk sted: Vejle

Re: Java eller flash problemer

Indlægaf laoshi » 9. dec 2011, 15:59

Jamen så må du hellere gå til Softwarecenter og vælge at installere:
- Begrænsede supplerende programmer til Ubuntu (det kaldes pakken faktisk!)
- Adobe Flash plugin 10
- og (kun hvis du kører et 64-bit-system) Udvidelsesmodul til Adobe flash
"Von guten Mächten wunderbar geborgen
erwarten wir getrost was kommen mag.
Gott ist mit uns am Abend und am Morgen
Und ganz gewiss an jedem neuen Tag"

(Dietrich Bonhoeffer 1906-1945)

http://www.stromata.dk
https://wiki.ubuntu.com/FlemmingChristensen
https://launchpad.net/~laoshi

Stra
Indlæg: 3099
Tilmeldt: 16. jun 2007, 10:26
Geografisk sted: Ikast-Herning

Re: Java eller flash problemer

Indlægaf Stra » 9. dec 2011, 16:08

Det er fordi du ikke får det hele med (Arvi der skal rettes i faq)

Der manlger flashplugin-installer til 32 bit maskine eller flashplugin-downloader til 64 bit maskine.

Du kan gøre det således

Kode: Vælg alt

sudo apt-get install flashplugin-installer flashplugin-downloader

men som Ajenbo skriver vil det ikke hjælpe på dit aktuelle problem.

Der skal du følge Lasohi s link installering af Shockwave
stra
Bruger Ubuntu 20.04 og 21.10 + lubuntu 20.04

kent a
Indlæg: 695
Tilmeldt: 31. dec 2009, 10:07
Geografisk sted: Erslev på Mors

Re: Java eller flash problemer

Indlægaf kent a » 9. dec 2011, 16:14

laoshi skrev:Jamen så må du hellere gå til Softwarecenter og vælge at installere:
- Begrænsede supplerende programmer til Ubuntu (det kaldes pakken faktisk!)
- Adobe Flash plugin 10
- og (kun hvis du kører et 64-bit-system) Udvidelsesmodul til Adobe flash


Den er hentet og installert fra centet men det virker stadig ikke...
Lubuntu 18.04 LTS

AJenbo
Admin
Indlæg: 20599
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Java eller flash problemer

Indlægaf AJenbo » 9. dec 2011, 19:10

Stra skrev:som Ajenbo skriver vil det ikke hjælpe på dit aktuelle problem.

Der skal du følge Lasohi s link installering af Shockwave

Brugeravatar
Christian.Arvai
Admin
Indlæg: 10715
Tilmeldt: 26. apr 2008, 19:27
IRC nickname: Christian_Arvai
Geografisk sted: Holeby - Lolland

Re: Java eller flash problemer

Indlægaf Christian.Arvai » 9. dec 2011, 20:20

Stra skrev:Det er fordi du ikke får det hele med (Arvi der skal rettes i faq)

Der manlger flashplugin-installer til 32 bit maskine eller flashplugin-downloader til 64 bit maskine.

Du kan gøre det således

Kode: Vælg alt

sudo apt-get install flashplugin-installer flashplugin-downloader

men som Ajenbo skriver vil det ikke hjælpe på dit aktuelle problem.

Der skal du følge Lasohi s link installering af Shockwave

Vi arbejder på den kommando lige nu. Problemet er at der er kommet nye pakker, og at dem til 32 og 64 laver en konflikt, så vi skal lige have den til at skelne imellem 32 og 64bit (vi har løst det meste nu).

EDIT :

Vi har lavet den nu, og den ligger til "test" i sandkassen https://ubuntudanmark.dk/forum/viewtopic.php?f=33&t=15267
Med venlig hilsen Christian

"We can only see a short distance ahead, but we can see plenty there that needs to be done." -- Alan Turing

Tilbage til "Andre systemer"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster