Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS? Emnet er løst

Forum for support til grafik og lydkort.
AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 13. maj 2012, 01:19

Så har jeg lige tested det samme Intel kort som du har i Ubuntu 12.04. Opløsningen virker fint, og jeg kan godt se youtube. Der er selføllige ingen acceleration, men et går lige at bruge det til simple ting.

Det køre faktisk forbavsende godt på den her 2.8Ghz P4 med 1GB DDR ram :)

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 14. maj 2012, 19:25

Puha, så lykkedes det at komme igennem. Nu sidder jeg med sort skærm igen på min egen og kan ikke komme på nettet. Lige nu sidder jeg på en bekendts bærbare med Windows 7 tilsluttet noget mobilt bredbånd. Jeg skal aflevere denne bærbare ved 21.tiden i aften.
Spændt på om dette svar når ind på forum. Her kan jeg da se knapperne.

Jeg har eksperimenteret fra i fredags, og har formateret mit C- og D-drev og installeret Win98 og WinXP igen - og det kører fint. MEN da jeg så ville installere Ubuntu fra WinXP fik jeg en sort skærm med denne besked:

Kode: Vælg alt

(process:264) GLIB WARNING** getpwuid_r ()
Failed due to "unknown user ID" (0)

Den besked kommer jo nok fordi jeg har en Ubuntu partition med et password - det skete også sidst da jeg forsøgte, men da var jeg heldig alligevel at kunne installere 10.10, hvorefter jeg opgraderet til 11.04, men så heldig var jeg ikke denne gang, desværre.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?  Emnet er løst

Indlægaf AJenbo » 18. maj 2012, 23:05

Seneste nyt til dem der event måtte læse med.

Grafikkort ser ud til at virke fint men init display skulle skiftes fra "Onboard/AGP" til "PCI".

DVD-drevet er lidt sløgt men kan godt starte og installere hvis man er lidt tolmodig. Drevet var vist også blevet deaktiveret i BIOS.

Maskinen køre nu med Ubuntu som primær system med MBR på hversin disk så man kan skifte hvis der bliver GRUB problemer en anden gang.

En del af programmerne fungere fint via Wine 1.5.3, men det kritiske Win98 er pt. ustabil hvilket ser ud til at have noget at gøre med nogle lydfiler i mp3 den har svært ved at afspille.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 23. maj 2012, 17:35

Jeg lage mærke til at du i windows køre med en støre mus en normalt, her er lige en guide til hovrdan du får det samme i Ubuntu:
http://askubuntu.com/questions/126491/how-do-i-change-the-cursor-and-its-size

Der er desuden en del indstillinger under Tilgængelighed der kan hjælp med at gøre tingende tydeligere.

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 5. jun 2012, 22:59

AJenbo skrev:Seneste nyt til dem der event måtte læse med.
DVD-drevet er lidt sløgt men kan godt starte og installere hvis man er lidt tolmodig. Drevet var vist også blevet deaktiveret i BIOS.

Ja, du kunne få den til det, men jeg kan ikke.

AJenbo skrev:Maskinen køre nu med Ubuntu som primær system med MBR på hversin disk så man kan skifte hvis der bliver GRUB problemer en anden gang.

Jeg startede op i går for første gang, og satte mig lidt ind i Unity - startede uden problemer igen idag, men så ville jeg lige tjekke noget i WinXP, og efter at have været derinde, ville maskinen ikke starte Ubuntu op igen! Efter adskillige forgæves forsøg, tog jeg siden af kabinettet og fjernede strømstikket til hd1, og så kunne jeg starte op i Ubuntu.
Kort sagt: maskinen starter ikke op efter hvad der står i BIOS, så situationen er uholdbar. Dels fordi det er upraktisk at køre uden at maskinen er beskyttet mod støv fra siden af kabinettet og dels fordi det er besværligt, hvis jeg skal pille strømstikket ud hver gang jeg vil i Ubuntu - øv - øv.

AJenbo skrev:En del af programmerne fungere fint via Wine 1.5.3, men det kritiske Win98 er pt. ustabil hvilket ser ud til at have noget at gøre med nogle lydfiler i mp3 den har svært ved at afspille.

Så langt er jeg ikke nået endnu, men jeg finder vel ud af at starte Wine op på et tidspunkt :)

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 5. jun 2012, 23:00

AJenbo skrev:Jeg lage mærke til at du i windows køre med en støre mus en normalt, her er lige en guide til hovrdan du får det samme i Ubuntu:
http://askubuntu.com/questions/126491/how-do-i-change-the-cursor-and-its-size

Der er desuden en del indstillinger under Tilgængelighed der kan hjælp med at gøre tingende tydeligere.

Tak for henvisningen, det må jeg se på senere, når jeg har fået installeret de vigtigste programmer.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 6. jun 2012, 03:57

Wine er ikke noget du selv skal starte, programmerne køre automatisk igennem det når du åbner dem som på normal vis.

Hvis du kan få startet Ubuntu op med begge harddiske kan du installere dens MBR på din hoved harddisk så den altid vil starte uanset hvilken disk din BIOS beslutter sig for at prøve først:

Kode: Vælg alt

sudo grub-install --root-directory=/ /dev/sda


Inden du køre den kommando vil jeg dog forslå du laver et backup af din Windows MBR med denne kommando:

Kode: Vælg alt

sudo dd if=/dev/sda of=~/WindowsXP-MBR.bin bs=446

(bliver gemt i din hjemmemappe)

Kan du ikke få den til at starte i Ubuntu med begge diske i samtidig er her et par forslag.
1) Sæt hver harddisk på sit eget IDE kabel som master, hav din Windows disk på IDE2, så burde BIOS starte far din Ubuntu disk. Windows disken vil dog sandsynligvis ikke længere være /dev/sda og de overstående kommandoer skal tilrettes. Her efter kan du flytte begge diske tilbage som før og systemet burde nu altid starte korrekt. Der er ingen skade sket hvis du kommer til at lave ændringen på det forkert drev.

2) Start en anden Ubuntu, enten via Wubi fra Windows XP eller ved at forsøge et pargange fra DVD-drevet. Din root vil her ikke være / og skal først monteres, og --root-directory= skal tilrettes. Root er den disk hvor mappen boot ligger på. Når den er monteret vil den have en sti i retningen af /media/63d6856f-2c22-4b38-816f-9a1ed6c601d0/ eller /media/Ubuntu/. Husk at afinstallere Ubuntu i Windows XP når du er færdig. Denne metode har den ulempe at hvis du kommer til at skrive root-directory forkert vil du ikke kunne starte fra den disk som du skriver til (du vil stadig kunne starte fra den anden).

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 6. jun 2012, 13:35

AJenbo skrev:Wine er ikke noget du selv skal starte, programmerne køre automatisk igennem det når du åbner dem som på normal vis.

OK, det udforsker jeg senere :)

AJenbo skrev:Hvis du kan få startet Ubuntu op med begge harddiske kan du installere dens MBR på din hoved harddisk så den altid vil starte uanset hvilken disk din BIOS beslutter sig for at prøve først:

Kode: Vælg alt

sudo grub-install --root-directory=/ /dev/sda


Det har jeg gjort og den melder:

Kode: Vælg alt

birthe@birthe-MS-6714:~$ sudo grub-install --root-directory=/ /dev/sda
[sudo] password for birthe:
Installation finished. No error reported.
birthe@birthe-MS-6714:~$

men jeg kan ikke finde den i roddrevet?

AJenbo skrev:Inden du køre den kommando vil jeg dog forslå du laver et backup af din Windows MBR med denne kommando:

Kode: Vælg alt

sudo dd if=/dev/sda of=~/WindowsXP-MBR.bin bs=446

(bliver gemt i din hjemmemappe)

Det har jeg også gjort, og den ligger i min hjemmemappe, men jeg kan ikke læse den eller åbne den. Men i TotalCommander kan man vælge "vis" filen, det er en af mange grunde til, at jeg er så begejstret for TotalCommander.

Og det næste du foreslår med at sætte harddiskene på hver sit kabel som master tænkte jeg på. Tak for din vejledning, jeg har printet den ud, så jeg har den liggende :)
Lige nu kører jeg Ubuntu med begge harddiske tilsluttet og det går fint - hvad der så sker hvis jeg skifter til Windows må tiden vise.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 6. jun 2012, 13:45

Husk at tage backup med dd før du overskriver med grub-install, ellers har du jo bare taget backup af grub som du let kan få igen, xp opstarteren er lidt sværere at skaffe.

MBR er kode først på harddisken inden partitionerne, så der er ikke noget at se i roden. Mht. at åbne .bin filen så er det 16bit realmode 386 maskin kode, så det er ikke rigtig noget man åbner og kigger på. Den vil forsten være låst da den er ejet af root og ikke dig, det kan du ændre med følgende kommando:

Kode: Vælg alt

sudo chown birthe:birthe ~/WindowsXP-MBR.bin

Hvad viser TotalCommander hvis du trykker det på filen? Hvis du vil se indholdet af den kan du bruge bless, jeg tvivler dog på du får særlig meget ud af det, men måske kan du se om det er Windows eller GRUB du har fået gemt ud fra noget af det tekst der er i den.

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 7. jun 2012, 23:33

AJenbo skrev:Husk at tage backup med dd før du overskriver med grub-install, ellers har du jo bare taget backup af grub som du let kan få igen, xp opstarteren er lidt sværere at skaffe.

Jeg har gjort det i den rigtige rækkefølge, men jeg har endnu ikke været i Windows, så jeg ved ikke hvad TotalCommander viser. Jeg er på vej til København og ser på det og resten du skriver, når jeg er tilbage i næste uge.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 8. jun 2012, 09:05

Du burde i øvrigt godt kunne installere TotalCommander nu hvor du har Wine på maskinen.

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster