Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS? Emnet er løst

Forum for support til grafik og lydkort.
birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 17. apr 2012, 01:14

Jeg slog onboard grafikken fra, monterede mit Nvidia kort i en pci-port, satte skærmkablet i det rette sted, startede computeren og valgte Ubuntu - og chok. Der kom en lang, lang liste på sort skærm, hvoraf jeg kun skriver en linje og slutkonklusionen:

Kode: Vælg alt

[62.950805] Corrupted low memory at c000fffc (fffc phys) = 31676001
Memory corruption detected in low memory.

Så Ubuntu startede altså ikke, jeg måtte slukke maskinen på tænd/sluk knappen. Efter utallige genstarter lykkedes det at komme ind i BIOS og slå onboard grafikken til igen, så jeg kan bruge masinen. Men i BIOS er der jo flere steder, hvor man kan stille noget med grafikkort, så jeg er i tvivl om hvordan jeg skal stille de forskellige valgmuligheder?

PnP/PCI Configurations:
PCI/VGA Palette Snoop - her kan jeg vælge mellem enabled og disabled. Den er disabled nu.

Integrated Peripherals:
Init Display First - her kan jeg vælge mellem onboard/AGP og PCI slot. Den står til onboard/AGP nu.

Advanced Chipset Features:
On-Chip VGA - her kan jeg vælge mellem enabled og disabled. Den står til enabled nu.
On-Chip Frame Buffer Size - her kan jeg vælge mellem 1MB og 8MB. Den står til 8MB nu.
Boot Display: her kan jeg vælge mellem Auto - CRT - TV - EFP. Den står til Auto nu.

Hvad betyder fejlmeldingen på den sorte skærm?
Og hvad gør jeg for at komme ind i Ubuntu, så jeg får mulighed for at installere en driver til kortet?

Artificial Intelligence
Indlæg: 2098
Tilmeldt: 18. nov 2006, 10:21
Geografisk sted: Køge

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf Artificial Intelligence » 17. apr 2012, 07:14

Integrated Peripherals:
Init Display First - her kan jeg vælge mellem onboard/AGP og PCI slot. Den står til onboard/AGP nu.


Prøv at slå den til PCI.

Ud over det, har du prøvet og se om ikke dit nvidia kort virker uden at du ændrer i BIOS?

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 17. apr 2012, 10:00

Disabled
Pci
Disabled
1
Auto

Fejlen ser ud til at være en ram fejl, prøv at køre memtest86+ på maskinen.

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 19. apr 2012, 18:10

AJenbo skrev:Disabled
Pci
Disabled
1
Auto

Fejlen ser ud til at være en ram fejl, prøv at køre memtest86+ på maskinen.


Det nåede jeg ikke, før det gik helt galt, for der må være noget andet helt galt.Og det har der været hele tiden, for når jeg har klikket på ikonet "Sysinfo" skete der ingenting. Sådan skal det ikke være.
I påsken da min nørd-ven var her, installerede vi Partition Magic under WinXP - og PM viste BAD for den disk som Ubuntu ligger på. PM som også kan læse Linux, kunne slet ikke læse den harddisk. Og nu har Linux bekræftet at der er en fejl i filsystemet ext3 (se længere nede).
Da jeg (i BIOS) rettede On-Chip Frame Buffer Size til 1MB, kunne jeg ikke komme ind i WinXP, så jeg rettede tilbage til 8MB. Grafikkortet understøtter WinXP, og jeg har installeret driveren til det, men fik en blå skærm med en melding om, at en af diskene skulle kontrolleres for konsistens. Så den kontrollerede og gav besked om det drev WinXP ligger på. Jeg kunne altså ikke komme ind i WinXP.

Jeg forsøgte så at gå i Win98 - sort skærm med beskeden:
"Der er ikke tilstrækkelig hukommelse til at initialisere Windows. Afslut et eller flere hukommelsesprogrammer eller fjern unødvenige programmer fra config.sys og autoexec.bat og genstart computeren. Tryk på en vilkårlig tast for at fortsætte. Sort skærm. Kunne ikke komme ind i Win98.

Genstartede og gik så ind i Linux: Sort skærm og en lang, lang fejlmeddelelse, der sluttede med:

Kode: Vælg alt

EXT3-fs error (device sdb1):
ext3-lookup: deleted inode reference d: 141469
birthe-MS-6714 login:


Jeg skrev mit login, og fik denne besked:

Kode: Vælg alt

Ubuntu 10.10 birthe-MS-6714 tty1


Genstartede - sort skærm med teksten:

Kode: Vælg alt

Error out of partition
grub resque>


Så hvad gør jeg nu - hvad skal jeg skrive ved grub resque>?

Jeg forsøgte at boote fra CD-ROM drevet med en Linux CD, men det kan jeg ikke for CD-ROM drevet er eksternt og tilsluttet en USB-port. Og Ubuntu eller grub har jo overskrevet MBR, så jeg heller ikke kan komme ind via Windows eller DOS-prompten.

Jeg kan slet ikke få forbindelse til mine harddiske, og dette er sendt fra min anden pc med Win98SE (ikke særlig sikkert, men den eneste måde jeg kunne komme på forum på).

Er bortrejst nogle dage, men tilbage igen på tirsdag. Håber virkelig der er en måde, jeg kan komme ind via det der "grub resque>".

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 19. apr 2012, 23:15

Det lyder for mig som om du stadig ikke har haft sat det nye grafikkort i ellers burde On-Chip Frame Buffer Size ikke have nogen indflydelse da on bord grafikkortet så ikke længere er i brug. Den blå skræm i XP er muligvis også fordi du har installeret det nye grafikkort uden at have haft det sat korrekt i. Har du sluttet skærmen til det nye kort? Og kommer der billed på skærmen når comptueren tænder? Du burde kunne afinstallere driveren ved at starte Windows i fejlsikker tilstand.

Da Windows XP ingen ting har på Linux partitionen og normalt heller ikke lan læse fra en Linux partition vil den tildstand ikke have nogen indflydelse på din windows installation. Men er det samme fysiske disk kunne det jo være at det er selve harddisken der er beskadiget, prøv at åben Diskredskaber i Ubuntu og se om SMART status for din harddisk er ok.

Windows 98 kan ikke håndtere mere end 2GB ram, fik du tested om systemet kørte efter du satte de nye ram i? Der er desuden også en fejl i win98 der gør at man kan løbe tør for ram hvis man har over 512MB.

Det er ikke umuligt at Parrtition Magic har skadet dine partitioner. Hvis du har installeret Ubuntu efter version 9.04 vil din partition være EXT4 og ikke EXT3 hvis Parition Magic har forsøgt at gøre din EXT4 til en EXT3 kan det være dette der er gået galt. "grub resque>" betyder at den ikke kan finde din system partition hvor den forventede det. Det fremgår af Wikipedia at Parititon Magic blev droppet af Symatec i 2009 og den sidste store opdatering til programmet var i 2003. Så for et værktøj der har med noget så følsom at gøre som paritionerne i dit system vil jeg sige det er på grænsen til at være mere farligt en gavnligt. I stedet bør du nok bruge GParted som faktisk er på Ubuntu Live cd'en og software centeret.
GParted kan faktisk håndtere langt flere Paritions typer end Parition Magic så det var nok noget din nørd ven skulle kigge lidt på. Bemærk dog at der er en mindre fejl i den udgave der kommer med 11.10 når man ændre NTFS paritioner.

Grub resque er ikke lige frem det letteste at arbejde med, men vi kan lige se lidt på det.

Er du sikker på maskinen ikke kan starte fra et USB cd drev? Ellers vil jeg forslå du laver en live-USB fra en anden computer og starter op fra den, det kræver blot en 1GB USB disk.
En 3 mulighed er at sætte harddisken i en anden computer, helt noget med Ubuntu :)

Artificial Intelligence
Indlæg: 2098
Tilmeldt: 18. nov 2006, 10:21
Geografisk sted: Køge

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf Artificial Intelligence » 21. apr 2012, 12:34

Dumt spørgsmål, men har du husket at sætte strøm til grafik-kortet? Jeg bruger normalt kun den tungere enden af grafikkort og de kræver, at kortet bliver forsynet med strøm.

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 26. apr 2012, 17:29

Artificial Intelligence skrev:Dumt spørgsmål, men har du husket at sætte strøm til grafik-kortet? Jeg bruger normalt kun den tungere enden af grafikkort og de kræver, at kortet bliver forsynet med strøm.

Forstår vist ikke hvad du mener.
Jeg har sat grafikkortet i PCI-porten og regner med at det får strøm automatisk.

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 26. apr 2012, 18:09

AJenbo skrev:Og kommer der billed på skærmen når comptueren tænder?

Nej, der kommer intet billede, når computeren tænder. Kun denne meddelelse:

Kode: Vælg alt

Error out of partition
grub rescue>


Jeg er blevet klar over noget med Win98, men hverken den eller WinXP har nogen betydning nu! Det eneste der betyder noget er, hvad jeg skal skrive ved prompten grub rescue?

Partition Magic kan ikke have skadet mine partitioner, for vi har intet foretaget os i programmet - kun installeret det i håb om at der var en funktion, så jeg kunne flytte nogle programmer i Windows fra et drev til et andet. Det var der i en ældre version, men ikke i den nyeste, så vi har intet gjort i programmet.

Det er mig der har installeret både Ubuntu 10.04 og Ubuntu 10.10 med EXT3, og det har jo fungeret fint siden jeg installerede første gang i december sidste år.

AJenbo skrev:Grub resque er ikke lige frem det letteste at arbejde med, men vi kan lige se lidt på det.

Ja tak, og det haster desværre, for den computer jeg bruger nu, vil ikke starte hveranden gang, så jeg aner ikke hvornår jeg kan læse evt. svar.

AJenbo skrev:Er du sikker på maskinen ikke kan starte fra et USB cd drev? Ellers vil jeg forslå du laver en live-USB fra en anden computer og starter op fra den, det kræver blot en 1GB USB disk.
En 3 mulighed er at sætte harddisken i en anden computer, helt noget med Ubuntu :)

Det du foreslår kan overhovedet ikke lade sig gøre, jeg har kun denne anden computer med Win98SE og 256MB RAM, og den vil ikke starte hveranden gang jeg forsøger. Faktisk kan jeg ikke engang komme på netbank med den, fordi både Firefox og java er forældet.

Jeg kan ikke starte maskinen fra et USB cd drev. Så tog jeg et internt CD-ROM drev fra en anden gammel computer og satte i, men den vil heller ikke boote fra det drev.
Jeg kan ikke boote fra CD-ROM drevet hverken med Ubuntu 10.04 eller 10.10 CD'en.
Jeg kan heller ikke boote med GParted-Live CD'en.
I det hele taget kan jeg ikke få forbindelse til harddisken. Uanset hvilken boot-rækkefølge jeg vælger i BIOS, kommer den sorte skærm med meddelelsen:

Kode: Vælg alt

Error out of partition
grub rescue>


Hvis jeg ikke kan skrive noget ved "grub rescue" og få forbindelse til harddisken, så bliver jeg nødt til at pille både grafikkortet og de nye RAM ud og sætte de gamle RAM i, og så prøve at boote fra en "Clean Boot" diskette fra floppy-drevet. Så jeg håber du kan sige noget om, hvad jeg skal skrive ved

Kode: Vælg alt

grub rescue>

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 27. apr 2012, 01:24

birthe skrev:
Artificial Intelligence skrev:Dumt spørgsmål, men har du husket at sætte strøm til grafik-kortet? Jeg bruger normalt kun den tungere enden af grafikkort og de kræver, at kortet bliver forsynet med strøm.

Forstår vist ikke hvad du mener.
Jeg har sat grafikkortet i PCI-porten og regner med at det får strøm automatisk.

Det lyder som om det må få strøm nok, men det er ikke usansynligt et morderne grafikkort ville kræve mere estrøm end PCI porten kan levere:
Billede
(der findes normalt 4 forskellige strøm stik)

Hvis det er denne du har kan jeg do ikke se et sådan stik på billedet:
Billede

birthe skrev:
AJenbo skrev:Og kommer der billed på skærmen når comptueren tænder?

Nej, der kommer intet billede, når computeren tænder. Kun denne meddelelse:

Kode: Vælg alt

Error out of partition
grub rescue>


Det er et billed for så vidt vi ønsker det. Alt det forgående tæller også.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 27. apr 2012, 01:39

birthe skrev:I det hele taget kan jeg ikke få forbindelse til harddisken. Uanset hvilken boot-rækkefølge jeg vælger i BIOS, kommer den sorte skærm med meddelelsen:

Kode: Vælg alt

Error out of partition
grub rescue>


grub rescue er del 1/3 som er indlæst fra din harddisk du kan godt komme i forbindelse med den.

Der er ikke en magisk kommando du kan skrive i grub rescue da det afhænger af dine paritioner, det er også meget begrænset funtioner man har og jeg husker det ikke særlig tydeligt så jeg vil gerne at vi forsøger alle andre muligheder først. Det ville også gøre det meget lettere at vide hvilken tilstand din harddisk er i.

birthe skrev:
AJenbo skrev:Er du sikker på maskinen ikke kan starte fra et USB cd drev? Ellers vil jeg forslå du laver en live-USB fra en anden computer og starter op fra den, det kræver blot en 1GB USB disk.
En 3 mulighed er at sætte harddisken i en anden computer, helt noget med Ubuntu :)

Det du foreslår kan overhovedet ikke lade sig gøre, jeg har kun denne anden computer med Win98SE og 256MB RAM, og den vil ikke starte hveranden gang jeg forsøger.

Det er godt nok ikke Ubuntu, men der for burde du godt kunne slutte disken til maskinen og så tilgå din FAT partitoner så du eventuelt kan få backup af dine filer, og se om partitionerne stadig er intakte.

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 27. apr 2012, 02:00

birthe skrev:Faktisk kan jeg ikke engang komme på netbank med den, fordi både Firefox og java er forældet.

Ja så vidt jeg kan se fedder du rundt med Firefox 1.0.3 :(
Selv om det ikke er det problem du prøver at løse vil jeg faktisk forslå dig at opgradere til 2.0.20 som er den seneste version der kan fungere på Windows 98 uden at man skal ud i mærkelige krumspring:
http://www.oldapps.com/firefox.php?old_firefox=7#download

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 27. apr 2012, 12:34

Ok her kommer den første GRUB kommando:

Kode: Vælg alt

set root=(hd0,0)
chainloader +1
boot

0,0 betyder hardisk 1, partition 1 så hvis du har flere diske eller windows ikke ligger på den første partition skal du ændre de tal.

Skal du have startet din linux kan du læse intrukserne her:
https://help.ubuntu.com/community/Grub2#Rescue_Mode_.28.27.27grub_rescue.3E.27.27.29_Booting

Hvis det lykkeds dig at lave en boot disk (cd eller en vens computer til at lave en usb) så kan du fikse det meget let via denne guide:
https://ubuntudanmark.dk/blog/artikler/2011/03/17/geninstaller-grub2/

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 29. apr 2012, 20:03

AJenbo skrev:
birthe skrev:
Artificial Intelligence skrev:Dumt spørgsmål, men har du husket at sætte strøm til grafik-kortet? Jeg bruger normalt kun den tungere enden af grafikkort og de kræver, at kortet bliver forsynet med strøm.

Forstår vist ikke hvad du mener.
Jeg har sat grafikkortet i PCI-porten og regner med at det får strøm automatisk.

Det lyder som om det må få strøm nok, men det er ikke usansynligt et morderne grafikkort ville kræve mere estrøm end PCI porten kan levere:
Billede
(der findes normalt 4 forskellige strøm stik)

Hvis det er denne du har kan jeg do ikke se et sådan stik på billedet:
Billede
birthe skrev:
AJenbo skrev:Og kommer der billed på skærmen når comptueren tænder?

Nej, der kommer intet billede, når computeren tænder. Kun denne meddelelse:

Kode: Vælg alt

Error out of partition
grub rescue>


AJenbo skrev:Det er et billed for så vidt vi ønsker det. Alt det forgående tæller også.

Redigeret af Birthe, søndag d. 29/4:
Undskyld, der gik kuk i mit svar, det smuttede ind imellem "quoterne".
Jeg skrev at det er det Zotac grafikkort jeg har, som du har lagt et billede af. Jeg kan heller ikke finde noget der ligner strømstik på det.
Senest rettet af birthe 29. apr 2012, 22:49, rettet i alt 1 gang.

birthe
Indlæg: 196
Tilmeldt: 20. dec 2010, 17:06
IRC nickname: busylady
Geografisk sted: Stege - Møn

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf birthe » 29. apr 2012, 20:11

AJenbo skrev:
birthe skrev:Faktisk kan jeg ikke engang komme på netbank med den, fordi både Firefox og java er forældet.

Ja så vidt jeg kan se fedder du rundt med Firefox 1.0.3 :(
Selv om det ikke er det problem du prøver at løse vil jeg faktisk forslå dig at opgradere til 2.0.20 som er den seneste version der kan fungere på Windows 98 uden at man skal ud i mærkelige krumspring:
http://www.oldapps.com/firefox.php?old_firefox=7#download/

Mange tak :)

AJenbo
Admin
Indlæg: 20855
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Sort skærm med Zotac GeForce GT 520 - 512MB - BIOS?

Indlægaf AJenbo » 29. apr 2012, 23:01

birthe skrev:
AJenbo skrev:
birthe skrev:Faktisk kan jeg ikke engang komme på netbank med den, fordi både Firefox og java er forældet.

Ja så vidt jeg kan se fedder du rundt med Firefox 1.0.3 :(
Selv om det ikke er det problem du prøver at løse vil jeg faktisk forslå dig at opgradere til 2.0.20 som er den seneste version der kan fungere på Windows 98 uden at man skal ud i mærkelige krumspring:
http://www.oldapps.com/firefox.php?old_firefox=7#download/

Mange tak :)

Firefox 1.0.3 svare til den der kom i Ubuntu 5.04 og 2.0.0.20 er 6.10.

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster