Install af driver til X-FI Xtrememusik lydkort

Forum for support til grafik og lydkort.
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Install af driver til X-FI Xtrememusik lydkort

Indlæg af Alfi-51 »

Hey

Har haft en del probs med mit lyd her under Linux og køre nu kun med mit onbord skod kort!
jeg vil gerne have mit creative kort til at køre. Det virker ikke som det skal med Linuxs egen
drivere så jeg har hentet creativs egne drivere, men jeg fatter ikke at installere dem ! :oops: :oops:

Så hvis der er en hjælpsom sjæl her inde som kan guide mig please!!! :wink:
der er en tekst fil med med en meget tynd install vejledning i

Quick install

=============
In terminal,

1) Goto source directory (OK)
2) Execute make command as root (?????)
make
make install

Jeg er i selve den mappe som det hele er pakket ud i, men skal lige have det sparket ind i hovedet
hvordan jeg skal skrive i terminalen tak.
Senest rettet af Alfi-51 28. dec 2010, 20:44, rettet i alt 1 gang.
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af lath »

Alfi-51 skrev:Hey

Har haft en del probs med mit lyd her under Linux og køre nu kun med mit onbord skod kort!
jeg vil gerne have mit creative kort til at køre. Det virker ikke som det skal med Linuxs egen
drivere så jeg har hentet creativs egne drivere, men jeg fatter ikke at installere dem ! :oops: :oops:

Så hvis der er en hjælpsom sjæl her inde som kan guide mig please!!! :wink:
der er en tekst fil med med en meget tynd install vejledning i

Quick install

=============
In terminal,

1) Goto source directory (OK)
2) Execute make command as root (?????)
make
make install

Jeg er i selve den mappe som det hele er pakket ud i, men skal lige have det sparket ind i hovedet
hvordan jeg skal skrive i terminalen tak.


root er brugernavnet for superbrugeren
su, gksu, sudo, og gksudo gør dig alle midlertidligt til superbrugeren root.

Gør sådan i stedet for:
  1. Programmer > Systemværktøjer > Root-Terminal
  2. Goto source directory << Det er meget vigtigt at placere dig i toppen af mappen med driverens kildekode!
  3. Kode: Vælg alt

    make
  4. Kode: Vælg alt

    make install

Jeg vil dog holde på at punktet hvor make køres, skal ske med almindelige bruger rettigheder, og til sidst køre make install som root brugeren (det har noget med sikkerhed at gøre).

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af Alfi-51 »

Hey

ok nu har jeg prøvet igen, men med samme resultat som før


make
make -C /lib/modules/2.6.35-23-generic/build M=/home/alf/sb
make[1]: Går til katalog '/usr/src/linux-headers-2.6.35-23-generic'
CC [M] /home/alf/sb/xfi.o
/home/alf/sb/xfi.c:14: fatal error: sound/driver.h: No such file or directory
compilation terminated.
make[2]: *** [/home/alf/sb/xfi.o] Fejl 1
make[1]: *** [_module_/home/alf/sb] Fejl 2
make[1]: Forlader katalog '/usr/src/linux-headers-2.6.35-23-generic'
make: *** [all] Fejl 2

dette er det der kommer efter make

og her er så efter: sudo make install
Copy module files...
cp: kan ikke udføre stat() 'ctxfi.ko': No such file or directory
make: *** [install] Fejl 1
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af AJenbo »

lath skrev:Programmer > Systemværktøjer > Root-Terminal

Tror ikke det er noget man normalt har.

Prøv det her istedet:
Åben programmer-tilbehør-terminal

Kode: Vælg alt

sudo bash

Skriv din adgangskode

Det er dog ikke noget man bør rodes ud i som normal bruger, er der ikke en deb pakke et sted, eller måske nogen der har sat en ppa op.
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af Alfi-51 »

AJenbo skrev:
lath skrev:Programmer > Systemværktøjer > Root-Terminal

Tror ikke det er noget man normalt har.

Prøv det her istedet:
Åben programmer-tilbehør-terminal

Kode: Vælg alt

sudo bash

Skriv din adgangskode

Det er dog ikke noget man bør rodes ud i som normal bruger, er der ikke en deb pakke et sted, eller måske nogen der har sat en ppa op.


1 Hvad sker der når jeg køre den komando der ?

2 Nej ikke jeg ved af altså det med ppa...

EDIT: det er den her driver jeg skal bruge hvis det er http://support.creative.com/downloads/d ... adId=10792
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64
AJenbo
Admin
Indlæg: 20862
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af AJenbo »

Der sker det samme som lath ville have dig til at gøre i første punkt af hans instrution (du får en terminal hvor du er root), så bagefter følger du bare resten af hans guide, og så håber vi eller creative ikke har lavet noget der laver ravage.
lath
Indlæg: 5095
Tilmeldt: 27. apr 2008, 02:16
IRC nickname: lars_t_h
Geografisk sted: Fyn

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af lath »

Alfi-51 skrev:Hey

ok nu har jeg prøvet igen, men med samme resultat som før


make
make -C /lib/modules/2.6.35-23-generic/build M=/home/alf/sb
make[1]: Går til katalog '/usr/src/linux-headers-2.6.35-23-generic'
CC [M] /home/alf/sb/xfi.o
/home/alf/sb/xfi.c:14: fatal error: sound/driver.h: No such file or directory
compilation terminated.
make[2]: *** [/home/alf/sb/xfi.o] Fejl 1
make[1]: *** [_module_/home/alf/sb] Fejl 2
make[1]: Forlader katalog '/usr/src/linux-headers-2.6.35-23-generic'
make: *** [all] Fejl 2

dette er det der kommer efter make

og her er så efter: sudo make install
Copy module files...
cp: kan ikke udføre stat() 'ctxfi.ko': No such file or directory
make: *** [install] Fejl 1


Da du er ved at kompile en device driver (Linux module, som kommer i *.ko filer) skal du installere de linux-headers der svarer til den kerne du har lige nu. Du skal måske også installere linux-src (kildekoden til kernen), som svarer til den kerne du har lige nu. Du skal helt sikkert installere buildessentials, og sikkert også nogle andre pakker.

Der er typisk en INSTALL fil hvor der står hvilke afhængigheder du manuelt selv skal sørge for at opfylde før en oversætte vil lykkedes.

Prøv at tjekke mit Kernel Lumen indlæg fra Sandkassen ud - det er måske noget for dig.

Du kan tilføje dit modul i /etc/modules. Det er en fil som fortæller kernen, hvilke moduler der skal indlæses ved boot. Egentligt er det modprobe programmet, der indlæser loadable modules. Det er kernen som starter modprobe, når den opdager at den mangler en device driver (og det er så kun den lidt tungere end ultralight udgave af forklaringen af hvad er foregår. Jeg har en bog hvor det er forklaret i - den fylder 40-50 sider, og er temmeligt tungt stof.

/Lars
Jeg er Software ingeniør (Diplomingeniør) i Informationsteknologi og indlejede systemer, hvor indlejrede systemer er computer (microcontroller) + elektronik i for eksempel et TV, en router, en vaskemaskine og den slags
zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af zob »

Prøv lige at køre denne her og post det url du får som resultat her i tråden:

Kode: Vælg alt

wget -O alsa-info.sh http://alsa-project.org/alsa-info.sh && bash ./alsa-info.sh


Prøv også lige at teste om det link du smed i din sidste post fører det sted hen du ønsker - jeg kan ikke se hvilken driver der er tale om.
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af Alfi-51 »

Hey

Kunne det være den her du vil se http://www.alsa-project.org/db/?f=f84d0 ... 541aeab3a4
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64
zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af zob »

Du har et aktivt lydkort på bundkortet, måske kan det give en konflikt. Kan du prøve at deaktivere det lydkort i BIOS?
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af Alfi-51 »

Hey

Det er prøvet, men det er ikke det der er galt. Vil tro at det måske er fordi at mit SB kort ikke helt
kan køre under linux øv..... og nu køre jeg så med det onbord og det virker da, men får en del
ekko på når jeg bruger skype som enligt heller ikke køre som den skal, men det er
jo noget helt andet tror jeg.
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64
zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af zob »

Ekko under brug af skype eller anden ip-telefoni sker ofte fordi højttalerne "føder" mikrofonen. Dvs. den lyd der kommer ud af højttalerne løber tilbage i mikrofonen i en af enderne. Det kan jo også være hos din samtalepartner. Den letteste måde at undgå det problem er ved at enten at bruge et headset eller et simpelt sæt hovedtelefoner så lyden ikke kommer ud i rummet og tilbage i mikrofonen. Hvis du hører ekkoet er det i virkeligheden mest sandsynligt at problemet er hos din samtalepartner og omvendt.
zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af zob »

Dit kort burde være understøttet: http://www.alsa-project.org/main/index. ... ative_Labs

Kan du ikke prøve at gøre mig en lille tjeneste. Gider du at prøve at skrive 'alsamixer' i en terminal.
Du kan copy-paste din mixer herind i tråden (den består bare af ASCII-kode). Den vil jeg mægtig gerne se.
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af Alfi-51 »

Hey

Nu er det så mig der ikke helt skriver så i kan forstå det......

det er ikke mig der høre ekko men i den anden ende de kan høre sig selv. Har dov også haft bøvl med det i windåse, men kun på
mit SB kort det onbord kan man slå noget fra så det ikke løber rundt i systemet altså lyden... i windåse.
måske der er en ligende funktion i Ubuntu ? jeg kan bare ikke finde ud af det endnu!




Card: Creative X-Fi F1: Help │
│ Chip: 20K1 F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: Master [dB gain: 0,00, 0,00] Esc: Exit │
│ │
│ │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │ │ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ │▒▒│ │ │ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │ │ │▒▒│ │ │ │ │ │
│ └──┘ └──┘ ├──┤ ├──┤ ├──┤ ├──┤ ├──┤ └──┘ ┌──┐ ├──┤ ├──┤ │
│ │OO│ │OO│ │MM│ │OO│ │MM│ │MM│ │MM│ │MM│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100<>100 0<>0 100<>100 100<>100 100<>100 100<>100 0<>0 50<>50 0<>0 0<>0 │
│ < Master > PCM Front Surround Center/L Side Line-in Mic Digit-IO S/PDIF-i S/PDIF-o │
│ │
│ │
│ │
└──────────────────────────────────────────────────────────────────────────────────────────────────────┘
var det det her du ville se ? har valgt mit SB kort her. Vil dov lige sige at jeg ikke har baghøjtalere på lige nu. så det er kun
sub, front og mic der skal virke indtil vidrer...
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64
Alfi-51
Indlæg: 204
Tilmeldt: 3. sep 2010, 21:28
Geografisk sted: Hobro

Re: Install af driver til X-FI Xtrememusik lydkort ???

Indlæg af Alfi-51 »

Hey

det med at skrive "alsamixer" det var jeg ikke klar over at man kunde og har nu rodet lidt rundt der inde og nu ser det sku ud til at virke !!!
nu mangler jeg bare at prøve mine baghøjtalere og center/sub men da jeg pt har måttet pakke min maskine halvvejs ned pga
ombygning så må det lige vente fik sådan en underlig lyd når jeg slog mine baghøjtalere til før så nu må vi se.
Indtil da 1000 tak for hjælpen
PSU Corsair TX750W & Asus ROG STRIX B450-F GAMING
Ryzen 5 3600 3.6GHz & Zalman CNPS7500-Cu LED
Kingston DDR4 PC3200 16GB CL16 HyperX Fury
Inno3D Geforce GTX 1060 3 GB
Samsung 970 EVO 500 GB NVMe & 2 TB Seagate 7200rpm SATA3
OS: Linux Mint x64 & Win 10 x64