ATI skærmdriver 10.5 Emnet er løst

Forum for support til grafik og lydkort.
michaelmunk
Indlæg: 14
Tilmeldt: 1. jun 2010, 12:53
Geografisk sted: Midtjylland

ATI skærmdriver 10.5

Indlægaf michaelmunk » 7. jun 2010, 22:50

Hej

Så for dælen, nu fik jeg vist gjort i nælderne. Har forsøgt at få 3d funktionerne (compiz etc.) til at køre under LTS 10.04, men nu kan jeg slet ikke komme af med fglrx pakken.. når jeg forsøger at lave en total purge af pakkerne.. jeg får følgende besked:

sudo apt-get remove -purge xorg-driver-fglrx fglrx-amdcccle

Kode: Vælg alt

@ubuntu1004:~$
E: Command line option 'p' [from -purge] is not known.
@ubuntu1004:~$ sudo apt-get remove --purge xorg-driver-fglrx fglrx-amdcccle
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package xorg-driver-fglrx is not installed, so not removed
The following packages will be REMOVED:
  fglrx-amdcccle*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 9.257kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 213747 files and directories currently installed.)
Removing fglrx-amdcccle ...
Setting up fglrx (2:8.723.1-0ubuntu4) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group gl_conf is broken.
update-alternatives: warning: skip creation of /usr/bin/amdcccle because associated file /usr/lib/fglrx/bin/amdcccle (of link group gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/share/applications/ubuntu-amdcccle.desktop because associated file /usr/share/fglrx/amdcccle.desktop (of link group gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/share/applications/ubuntu-amdccclesu.desktop because associated file /usr/share/fglrx/amdccclesu.desktop (of link group gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/bin/amdxdg-su because associated file /usr/lib/fglrx/bin/amdxdg-su (of link group gl_conf) doesn't exist.
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.723.1 DKMS files...

------------------------------
Deleting module version: 8.723.1
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.723.1 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.34-020634rc7-generic
Building for architecture x86_64
Building initial module for 2.6.34-020634rc7-generic

Error! Bad return status for module build on kernel: 2.6.34-020634rc7-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
dpkg: error processing fglrx (--configure):
 subprocess installed post-installation script returned error exit status 10
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_DK.utf8.cache...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.34-020634rc7-generic
Processing triggers for python-support ...
Errors were encountered while processing:
 fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)
@ubuntu1004:~$ sudo apt-get remove --purge xorg-driver-fglrx fglrx-amdcccle
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package xorg-driver-fglrx is not installed, so not removed
Package fglrx-amdcccle is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up fglrx (2:8.723.1-0ubuntu4) ...
update-initramfs: deferring update (trigger activated)
Removing old fglrx-8.723.1 DKMS files...

------------------------------
Deleting module version: 8.723.1
completely from the DKMS tree.
------------------------------
Done.
Loading new fglrx-8.723.1 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.34-020634rc7-generic
Building for architecture x86_64
Building initial module for 2.6.34-020634rc7-generic

Error! Bad return status for module build on kernel: 2.6.34-020634rc7-generic (x86_64)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.723.1/build/ for more information.
dpkg: error processing fglrx (--configure):
 subprocess installed post-installation script returned error exit status 10
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_DK.utf8.cache...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.34-020634rc7-generic
Processing triggers for python-support ...
Errors were encountered while processing:
 fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)


sudo lspci -v

Kode: Vælg alt

01:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]
   Subsystem: Acer Incorporated [ALI] Device 035c
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at c0000000 (64-bit, prefetchable) [size=128M]
   Memory at cc000000 (64-bit, non-prefetchable) [size=128K]
   I/O ports at 3000 [size=256]
   Expansion ROM at cc040000 [disabled] [size=128K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
   Capabilities: [100] Vendor Specific Information <?>
   Kernel driver in use: radeon
   Kernel modules: radeon


uname -a

Kode: Vælg alt

Linux ubuntu1004 2.6.34-020634rc7-generic #020634rc7 SMP Mon May 10 09:08:52 UTC 2010 x86_64 GNU/Linux


Grunden til denne kernel opdatering er at der er bedre support for min bærbare her. Acer Aspire TimelineX 5820TG

what the dælen do i do now ?
Senest rettet af michaelmunk 8. jun 2010, 07:45, rettet i alt 1 gang.
Ubuntu 10.10 Lucid Lynx 64-bit - Acer Aspire 5742G | Nvidia Geforce GT 420M | 3GB DDR3 RAM | 500GB HD

Warhawk
Indlæg: 1214
Tilmeldt: 29. maj 2008, 22:41
Geografisk sted: Esbjerg

Re: ati skærmdriver 10.5

Indlægaf Warhawk » 7. jun 2010, 23:22

Hejsa,

Du mangler at fjerne selve driveren, men den er dog ikke længere i brug.

Kode: Vælg alt

sudo aptitude purge fglrx && sudo aptitude update


Du har Radeon driveren i brug.
/Michael
---

Ubuntu 14.04 64-bit - XFS Lenovo ThinkPad W520 | i7-2860 Quad | nVidia Quadro 2000M | 16GB DDR3 RAM | 256GB Patriot Extreme Performance Warp SSD

michaelmunk
Indlæg: 14
Tilmeldt: 1. jun 2010, 12:53
Geografisk sted: Midtjylland

Re: ati skærmdriver 10.5

Indlægaf michaelmunk » 7. jun 2010, 23:40

tak det virkede... :)

men nu får jeg så når jeg forsøger at køre installationen med kommandoen

Kode: Vælg alt

sudo sh ./ati-driver-installer-10-5-x86.x86_64.run


Kode: Vælg alt

Created directory fglrx-install.VmAgBJ
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.732...................................../klippet lidt  i denne .....................................................................................................................
.....
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 7.5 64-bit
loki_setup: directory: (null)
DKMS part of installation failed.  Please refer to /usr/share/ati/fglrx-install.log for details
Removing temporary directory: fglrx-install.VmAgBJ


Kode: Vælg alt

/usr/share/ati/fglrx-install.log


Kode: Vælg alt

Creating symlink /var/lib/dkms/fglrx/8.732/source ->
                 /usr/src/fglrx-8.732

DKMS: add Completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
cd /var/lib/dkms/fglrx/8.732/build; sh make.sh --nohints --uname_r=2.6.34-020634rc7-generic --norootcheck....(bad exit status: 1)
0
0
[Error] Kernel Module : Failed to build fglrx-8.732 with DKMS
[Error] Kernel Module : Removing fglrx-8.732 from DKMS

------------------------------
Deleting module version: 8.732
completely from the DKMS tree.
------------------------------
Done.


kan det være min custom kernel som giver problemet ? og skal jeg i givet fald smide den ud og så ligge den officielle kernel på igen ?

/Michael
Ubuntu 10.10 Lucid Lynx 64-bit - Acer Aspire 5742G | Nvidia Geforce GT 420M | 3GB DDR3 RAM | 500GB HD

Warhawk
Indlæg: 1214
Tilmeldt: 29. maj 2008, 22:41
Geografisk sted: Esbjerg

Re: ati skærmdriver 10.5

Indlægaf Warhawk » 7. jun 2010, 23:53

Hej igen,

Der er en længere udredning på https://wiki.ubuntu.com/X/Troubleshooti ... deonDriver - prøv at følge den og se om det hjælper - ellers må du skrive igen.
/Michael
---

Ubuntu 14.04 64-bit - XFS Lenovo ThinkPad W520 | i7-2860 Quad | nVidia Quadro 2000M | 16GB DDR3 RAM | 256GB Patriot Extreme Performance Warp SSD

michaelmunk
Indlæg: 14
Tilmeldt: 1. jun 2010, 12:53
Geografisk sted: Midtjylland

Re: ati skærmdriver 10.5  Emnet er løst

Indlægaf michaelmunk » 8. jun 2010, 07:44

sådan nu virker alle 3d funktionerne igen.. jeg kan ihvertfald lave awn om til 3d og nu kan jeg også se cubeeffekten i compiz, så sagen er løst herfra.

Det var en kombination af den første kommando & den lange udredning nr. 2. samt at jeg skiftede tilbage til kernel 2.6.32 (standard kernel).

Nu vil jeg så overveje om jeg skal tage skiftet op igen til 2.6.34 / 35 for at få bedre understøttelse af min Laptop. :roll: :twisted:
Ubuntu 10.10 Lucid Lynx 64-bit - Acer Aspire 5742G | Nvidia Geforce GT 420M | 3GB DDR3 RAM | 500GB HD

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster