Ingen lyd - LØST

Forum for support til grafik og lydkort.
gormbach
Indlæg: 18
Tilmeldt: 22. nov 2009, 17:15

Ingen lyd - LØST

Indlægaf gormbach » 4. jun 2010, 00:54

Jeg har søgt lidt på forummet og kan se at manglende lyd er et meget normalt problem. Jeg har naturligvis sørget for at der skruet helt op for lyden og at den ikke er mutet men jeg har stadig ingen lyd. Heller ikke i hovedtelefonstikket.

Her er lidt info som jeg kan se i efterspørger:

Min computer er en Sony Vaio

kristian@kristian-laptop:~$ sudo lsb_release -a && uname -a
[sudo] password for kristian:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04 LTS
Release: 10.04
Codename: lucid
Linux kristian-laptop 2.6.32-22-generic #35-Ubuntu SMP Tue Jun 1 14:18:25 UTC 2010 x86_64 GNU/Linux

kristian@kristian-laptop:~$ lshw -C multimedia
WARNING: you should run this program as super-user.
*-multimedia
description: Audio device
product: Redwood HDMI Audio [Radeon HD 5600 Series]
vendor: ATI Technologies Inc
physical id: 0.1
bus info: pci@0000:01:00.1
version: 00
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=HDA Intel latency=0
resources: irq:17 memory:f0040000-f0043fff
*-multimedia
description: Audio device
product: 5 Series/3400 Series Chipset High Definition Audio
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 05
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=HDA Intel latency=0
resources: irq:22 memory:f5e00000-f5e03fff

kristian@kristian-laptop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

kristian@kristian-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC269

kristian@kristian-laptop:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2

kristian@kristian-laptop:~$ dmesg | grep -i alc
[ 0.000006] Calibrating delay loop (skipped), value calculated using timer frequency.. 4521.62 BogoMIPS (lpj=22608110)
[ 4.922766] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[ 28.442669] hda_codec: ALC269: BIOS auto-probing.

Håber i vil hjælpe
Senest rettet af gormbach 4. jun 2010, 14:10, rettet i alt 1 gang.

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Ingen lyd

Indlægaf zob » 4. jun 2010, 01:26

Tusind tak for din grundige research. Jeg plejer altid at skulle bruge de første 5 poster på at komme hertil hvor vi er nu. Jeg ville ønske jeg kunne sige nu at det gjorde alt meget lettere. Desværre ser det dog ud til at dit lydkort er dårligt understøttet i den nuværende alsa-version. Det kan derfor komme på tale at skulle opgradere din alsa-driver. Det er en smule langhåret, men der er heldivis en fyr der har lavet et script til det formål.
Først kan du lige se i tråden her (han ender med at få det til at virke efter en alsa-opgradering): http://ubuntuforums.org/showthread.php?t=1468048
Du behøver ikke følge alle de ting han bliver udsat for i tråden. De virker alligevel ikke for ham. Han finder løsningen nederst side 2, og henviser hertil: http://monespaceperso.org/blog-en/2010/ ... ynx-10-04/

Det er opskriften på en alsa-upgrade af den langhårede slags. Som sagt er der et script. Læs første post i denne tråd (den bliver løbende opdateret): http://ubuntuforums.org/showthread.php? ... ost6589810
Hvis du følger instruktionerne og downloader og installerer scriptet herfra får du den nyeste version af alsa.

Du kan måske også teste den nyeste version af alsa på en anden måde. Fedora 13 er lige udkommet og den kommer med nyeste version. De har vel en liveCD du kan køre. Så kan du se om du får lyd. Det var selvfølgelig ikke en anbefaling om at bruge Fedora i stedet, men så ville vi vide med større sikkerhed om det skyldtes alsa-driver-versionen.

Jeg sætter også lige denne ind til senere reference:
- ALSA: hda - Add fix-up for Sony VAIO with ALC269
Sony VAIO models with ALC269 need to initialize the pin 0x19 to VREF
ground or Hi-Z to make the headphone working. Other than that, model=auto
works fine, so let's use model=auto with a specific fix-up table.
Det er noget der gælder for nyeste version af alsa (1.0.23). Kilde: http://alsa-project.org/main/index.php/ ... 22_v1.0.23

Jeg er nødt til at gå i seng. Men nu har du da også lidt godnatlæsning. Fortæl endelig hvordan det går, hvis du kaster dig ud i en opdatering.

PS: På det citat jeg lige indsatte kunne det måske tyde på at der evt. skal tilføjes en linje til /etc/modprobe.d/alsa-base.conf

Kode: Vælg alt

gksu gedit /etc/modprobe.d/alsa-base.conf
Indsæt allernederst: options snd-hda-intel model=auto
Du kan selvfølgelig indsætte linjen nu og teste på nuværende version (kræver gem,luk,genstart), men jeg tror de mener det gælder for version 1.0.23.

gormbach
Indlæg: 18
Tilmeldt: 22. nov 2009, 17:15

Re: Ingen lyd

Indlægaf gormbach » 4. jun 2010, 02:26

Jeg fulgte guiden i http://monespaceperso.org/blog-en/2010/ ... ynx-10-04/ og nu virker det hele perfekt.

Tak for hjælpen

swotie
Indlæg: 542
Tilmeldt: 10. jan 2009, 08:31
Geografisk sted: Bjerringbro

Re: Ingen lyd

Indlægaf swotie » 4. jun 2010, 03:57

Vil du så ikke være sød at skrive [LØST] i emne linien i dit første indlæg
/Henrik

Ubuntu 20.04 64 bit

Lenovo ideacenter 310S, Pentium J4205 Quad, 8 GB Ram,canonscan lide 120 scanner

zob
Redaktør
Indlæg: 4430
Tilmeldt: 6. jan 2009, 22:01
Geografisk sted: København

Re: Ingen lyd

Indlægaf zob » 4. jun 2010, 09:41

Godt gået. Så var det åbenbart den alsa-driver-opdatering der skulle til.

Tilbage til "Grafik og lyd"

Hvem er online

Brugere der læser dette forum: [Crawler] og 1 gæst