Mus i Ubuntu 14.04

Spørgsmål, som ikke kan besvares i andre hardware-fora, bør stilles her.
bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Mus i Ubuntu 14.04

Indlægaf bo persen » 21. feb 2015, 13:49

I torsdags fik jeg hjælp til at installere ubuntu 14.04 på min bærbare Asus R510L. Den erstattede en windows 8, som jeg var (og er) stærkt irriteret på. Jeg er vældig tilfreds bortset fra, at hverken pegepladen eller mus (har prøvet 2 trådløse og en trådet) virker. Pegepladen slet ikke og musen kun lige efter opstart og så måske en gang imellem efterfølgende. Alle tre mus på samme måde. Den trådede virker dog måske lidt tiere.
Det gælder kun i programvinduer. På skrivebordet (jeg er virkelig ny bruger!) virker musen - næsten - hele tiden.
Håber I kan hjælpe
bo persen

Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

Re: Mus i Ubuntu 14.04

Indlægaf Blueeyez » 21. feb 2015, 14:30

Det lyder meget mærkeligt.
Er UEFI sat til legacy i bios? (Lige det eneste jeg kan komme på som kan påvirke mus og tastatur..)
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Mus i Ubuntu 14.04

Indlægaf AJenbo » 21. feb 2015, 15:12

Velkommen til forummet

Jeg har også svært ved at se hvad problemet kan skyldes, det at trackpad ikke virker kunne selvfølgelig være manglende drivere. Fungerede mus ellers fint under Windows?

Det ville også være godt hvis du kunne komme lidt nærmere ind på hvordan problemet viser sig. Der er ikke rigtig nogen forskel på om musen køre over et program eller desktoppen (som faktisk er fil håndteringen). Er det fordi programmerne ikke reagere på links?

mbjornbak
Indlæg: 380
Tilmeldt: 23. jan 2010, 18:49
IRC nickname: mbh
Geografisk sted: København

Re: Mus i Ubuntu 14.04

Indlægaf mbjornbak » 21. feb 2015, 15:34

Har du prøvet at klikke på tandhjulet i øverste højre hjørne> system settings>mouse & touchpad?

Der er måske ? gået ged i de indstillinger, du kan se der.
mbjornbak

bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Re: Mus i Ubuntu 14.04

Indlægaf bo persen » 22. feb 2015, 11:27

Det er alt sammen meget mystisk!
Umiddelbart efter åbning af PC'en virker musen (ikke pegepladen) i programvinduerne. Efter nogen tid virker kun curseren, ikke knapperne.
I går oplevede jeg at efter et lille hvil, begyndte musen at virke igen, for siden atter "at gå død".
Da jeg skulle kigge efter svar i dette forum for lidt siden, måtte jeg slukke og tænde igen, fordi jeg ikke kunne finde ud af at komme til login. Så virkede musen igen. Jeg kan sagtens åbne programmer, men når musen er stået af, må jeg lukke dem igen med "Alt + F4".
Jeg havde musen igang for at komme herind, men nu virker den allerede ikke igen. Det er jo uholdbart, at jeg skal genstarte hvert andet øjeblik?
Jeg er heller ikke sikker på, hvordan jeg får dette sendt. Nu må jeg se om nogle af de tastaturgenveje, jeg kender dur!
Tak for jeres forslag, men der er ikke rigtig nogen af dem har virket indtil nu!
Jeg venter spændt.
bo

bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Re: Mus i Ubuntu 14.04

Indlægaf bo persen » 22. feb 2015, 11:29

PS.:
Musen kom igang igen inden jeg sendte!
Men jeg glemte at fortælle at alle tre mus virker glimrende på min windowsmaskine.
bo

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Mus i Ubuntu 14.04

Indlægaf AJenbo » 22. feb 2015, 11:53

Er det nogle specefikke programmer du oplever det med?
Kan du stadig flytte vinduerne ved at holde alt nede og trække dem?
Se om du kan ændre størrelsen på vinduer.

Det er self. ikke en løsning, men prøv at se om ikke det er nok at logge ud og ind igen, så slipper du for at vente på at maskinen genstarter.

Hold øje med om der er noget bestemt du gøre (starte et bestemt program, ændre størrelsen på programmer) når problemet opstår.

Prøv at åbne en terminal (ctrl+alt+t) og kør denne koammando:

Kode: Vælg alt

xinput list

Den skulle fortælle dig hvilke ID og SLAVE nummer din mus har, dem skal du så bruge i den næste kommando. Du må også meget gerne give os info der fra da det kan hjælpe med at finde ud af hvad problemet med trackpad er.

Kode: Vælg alt

xinput reattach ID SLAVE


Jeg ville faktisk forslå at du prøver at opgradere til 14.10 og ser om det løser problemet, men så skal du være klar over at du fremover skal opgradere hver 6. måned (du får et 3 måneder vindue fra næste udgivelse til du senest skal opgrader), frem til du lander på 16.04 som vil være den næste LTS.

bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Re: Mus i Ubuntu 14.04

Indlægaf bo persen » 22. feb 2015, 13:13

Hej AJenbo
Jeg har oplevet problemet i alle de programmer (som jeg jo sagtens kan starte ved hjælp af musen), jeg har: Firefox, Libre Office, Audacity, the GIMP, Indstillinger osv.
Jeg har netop valgt 14.04 p.gr. af LTS. Jeg er frivillig på Radio Nordfyn, hvor vi i øjebklikket er i færd med at gå over til Ubuntu, jeg vil gerne undgå at skulle ændre på særlig meget over tid, og da slet ikke hvert ½ år, idet det forlyder at vi så risikerer problemer med afviklingsprogrammet Airtime. Men det kan jeg sige mere om, når vi er i gang på radioen.
Det lader til at problemet med min mus er on & off og pegepladen er jeg faktisk ligeglad med. Den har også altid irriteret mig. Men jeg værdsætter dine forsøg på at yde hjælp. Håber vi på et tidspunkt rammer ét eller andet.
bo

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Mus i Ubuntu 14.04

Indlægaf AJenbo » 22. feb 2015, 13:22

Ok, du vender bare tilbage når du har prøvet nogle af de forskellige ting jeg nævnte så kan vi begynde at grave dybere i en af retningerne. Jeg kan se at der var nogle liggende problemer for 4 år tilbage, men jeg har aldrig selv støt på det og kunne godt mistænke at det er et program eller indstilling du har fået lavet i opsætningen af din maskine som griber musen når den ikke skal. Du husker ikke at have installere nogle extra programmer omrking det tidspunkt hvor problemet startede første gang?

bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Re: Mus i Ubuntu 14.04

Indlægaf bo persen » 22. feb 2015, 13:49

Nu fik jeg jo hjælp til installationen, dvs jeg lavede ikke noget.
Men problemet har været der fra første minut.
Jeg lavede den første af dine kommandoer og citerer her første del:

Virtual core pointer id = 2 [master pointer (3)]
Virtual core XTEST pointer id = 4 [slave pointer (2)]
Logitech USB Optical mouse id = 9 [slave pointer (2)]
PS/2 Logitech Wheel mouse id =13 [slave pointer (2)]

Anden del hedder Virtual core keyboard id =3 [master pointer (2).
Jeg regner ikke med den er vigtig, men jeg sender om nødvendigt.
I øvrigt virker dit trick med at logge af.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Mus i Ubuntu 14.04

Indlægaf AJenbo » 22. feb 2015, 15:53

Så skal du prøve om følgende afhjælper problemet.

Kode: Vælg alt

xinput reattach 9 2


Jeg kan se at der også er en PS/2 mus. det kunne være din trackpad, men jeg er ikke sikker.

bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Re: Mus i Ubuntu 14.04

Indlægaf bo persen » 22. feb 2015, 16:41

Jeg har prøvet den reattach kommando, og indtil videre har musen virket.
Jeg prøvede også med PS/2 musen ( reattach 13 2) men pegepladen virker stadig ikke. Der er jo heller ikke noget hjul på! :o)
Men jeg tror/håber problemet med musen er løst.
Tusind tak for hjælpen.
bo

Nå, ikke helt, for nu holdt den op med at virke igen! Måtte logge af.

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Mus i Ubuntu 14.04

Indlægaf AJenbo » 22. feb 2015, 17:41

Det er ikke en kommando der løser problemet men en der måske kan genaktivere musen (nu uden at skulle logge af) og bringe os et skrid nærmere hvad problemet er. Derfor skal du først køre den når du har problemer med musen.

En track pad kan have et virtuelt scrollhjul. Nej kommandoen var ikke ment for at få trackpad til at virke.

bo persen
Indlæg: 8
Tilmeldt: 21. feb 2015, 13:30

Re: Mus i Ubuntu 14.04

Indlægaf bo persen » 23. feb 2015, 08:05

Når musen går død, og det gør den af og til stadigvæk, oplever jeg det som noget hurtigere at logge af end at køre kommandoen i terminalvinduet. begge dele virker. Måske vil jeg bruge kommandoen, hvis jeg har gang i et eller andet større projekt, som jeg ikke har fåå ået gemt, men i hvert fald i webbrowseren, f.eks. på denne side, vender den tilbage til der, hvor jeg var nået til. Det er et irriterende problem, men det får mig ind til videre ikke til at "fyre" ubuntu 14.04. Jeg kigger ind engang imellem, for at se om løsninger skulle vise sig!
Nå, igen tog jeg fejl! Kommandoen virker ikke hvis jeg har gang i noget, f. eks. denne side. Så log af kommandoen er foreløbigt eneste løsning.
Foreløbigt tak.
bo

AJenbo
Admin
Indlæg: 20860
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: Mus i Ubuntu 14.04

Indlægaf AJenbo » 23. feb 2015, 09:42

Ok, jeg må indrømme at jeg ikke ved hvor dan vi kommer videre herfra. Mest af alt ville jeg gerne prøve at køre henholdsvis lubuntu 14.04, 14.10 og ubuntu 14.04 (uden at installere) og se hvordan maskinen opføre sig der. Men hvis ikke du har lyst til det er jeg bange for at vi går lidt i stå her.

Ind til videre kan vi konkluderer at det hjælper at genstart det grafiske system, men at det ikke hjælper at genetablere musen. Det får mig blot til fortsat at tro det er et program du har fået installeret som griber musen.

Mht til at se om der bliver skrevet noget her inde så kan du sætte forummet til at sende dig en mail hvis der kommer ny indlæg i emnet.

Tilbage til "Overordnet hardware"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster