(LØST) fejl når jeg klikker ind på afdelinger..

Alt omkring ubuntudanmark.dk
Brugeravatar
Blueeyez
Forfatter
Indlæg: 885
Tilmeldt: 24. jul 2012, 21:33
IRC nickname: Blueeyez

(LØST) fejl når jeg klikker ind på afdelinger..

Indlægaf Blueeyez » 3. sep 2015, 01:20

Hvis jeg ikke er logget ind, så kan jeg ikke se de afdelinger der er.. Eller jeg kans e deres afdelingsnavne, men klikker jeg på dem får jeg følgende besked:

Du er blevet udelukket permanent fra dette board.

Kontakt venligst boardadministrator for yderligere oplysninger.

Årsag angivet for udelukkelse: Failed Login Attempt

Din IP-adresse er blevet udelukket.
Senest rettet af Blueeyez 8. sep 2015, 21:54, rettet i alt 1 gang.
* Linux Ubuntu 16.04 64 bit - I3, 4 GB DDR3 1600Mhz, intel 7260AC dual band wifi, Samsung EVO 850 250 GB SSD. - Abook Z510
* Asustor nas: AS-202T, AS-202TE & AS-604T
https://linuxviden.dk

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 3. sep 2015, 05:22

Ja, det er et kendt problem med vores meget aggressive spam filter. Vi er ikke helt 100% sikre på hvordan hvor i systemet det sker eller hvorfor den udløser når blot du vil se en side men ikke forummet (kan du eventuelt finde ud af om det er en bestemt type sider der påvirkes).

Det eneste vi kan konkludere er at din IP pt. figuere i en af de offentlige spam lister som siden tjekker mod. Du kan aktivt prøve at få den fjernet eller blot vente til den bliver fjernet fra listen igen.

Vi regner med problemet vil forsvinde helt når vi er færdige med at flytte siden over til phpBB 3.1, et projekt jeg arbejder på i det små pt.

Vi hade tidligere planer om at prøve at løse problemet med den nuværende side, men det lod sig aldrig gøre at finde nogen der var påvirket af problemet om som samtidig kunne hjælpe med at fejlsøger. Det eneste jeg ved er at de også ramte brugere der forsøgte at gå ind på Download siden.

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 3. sep 2015, 05:37

Ok, denne gang fik jeg faktisk selv problemet at se, og kunne der for finde frem til hvad det skyldes.

Det der sker er at en spam bot besøger siden, phpBB spam filter afviser den og denne afvisning gemmes så i cachen for siden som så vises til efterfølgende besøgende indtil cachen tømmes.
Problemet ses dermed ikke hvis man er logget ind i WP.

Din IP er dermed ikke i dårlig stand. Helt specefikt skyldes problemet denne IP: 78.138.97.90

Jeg kan komme på 2 løsninger:
a: Når en bot afvises bør spam filteret afvise med HTTP kode 403 (forbidden), disse bør så ikke gemmes af cachen.

b: Ikke teste for spammer når det blot handler om en side visning og ikket forsøg på at logge ind på siden/skrive indhold etc.

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 3. sep 2015, 06:16

Jeg har forsøgt at løse det ved at sætte phpBB til at sende en fejlkode 403, men det ser desværre ud til at den bliver overskrevet af WP med en 200 OK. Jeg må kigge nærmere på det nå jeg har lidt mere tid. For nu har jeg blot tømt cachen på siden så alle sider igen skulle være tilgængelige.

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 3. sep 2015, 06:29

Lille rettelse, fejlkoden bliver sendt korrekt men WP-supercache vælger stadig at cache siden.

Det ser ikke ud til at det er sådan lige til at løse uden at opgradere serveren til php5.4, men jeg vil prøve at hacke lidt på det.

Jimmyfj
Indlæg: 1700
Tilmeldt: 19. jul 2007, 19:35
Geografisk sted: Nordjylland

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf Jimmyfj » 3. sep 2015, 07:44

Jeg har et par gange oplevet at blive afvist allerede ved login. Her fik jeg at vide, at min login var afvist p.g.a. at min IP var registreret i sidens spamfilter.

What the (host) - Jeg har aldrig lavet noget derinde, som burde kunne skabe den besked?!

Så det er ikke kun visning af sider på domænet, der forhindres af fejlen men også login. Hmmm :shock:
"OM 100 ÅR ER ALTING GLEMT !"


Ubuntu - Dev-ed.
Linux User # 448500

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 3. sep 2015, 08:21

Problemet med cached afvisninger skulle nu være løst.

@Jimmyfj Jeg vil have brug for yderligere info om problemte for at kunne løse det, eks. IP og præcis url og handling. Kan du genskabe problemet pt? Det kan være du har fået en IP der tidligere har været brugt til spam af en anden, som sagt så er det hoved saligt globale lister vi støtter os op af og ikke noget vi selv sider og laver ud fra brugere her på forummet. Generelt er der meget fredeligt på selve forummet, der hvor der er ballade er med spam hackere der forsøger at register sig eller hackere der forsøger at gætte brugernes adgangskoder. Derfor er det nødvendigt at få en liste over dem der ikke skal have adgang før end første gang vi ser dem her på forummet.

Jimmyfj
Indlæg: 1700
Tilmeldt: 19. jul 2007, 19:35
Geografisk sted: Nordjylland

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf Jimmyfj » 3. sep 2015, 21:44

Fejlen, jeg fik, har kun optrådt to gange, og hver gang med den fejlmeddelse, AJenbo nævner:

Din logon er blevet afvist da din IP-adresse har været brugt til spam. Gætter på, at eneste vej rundt om den melding er en statisk IP.
"OM 100 ÅR ER ALTING GLEMT !"


Ubuntu - Dev-ed.
Linux User # 448500

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 3. sep 2015, 23:57

Er det efter du udfylder navn og adgangskode?

Jimmyfj
Indlæg: 1700
Tilmeldt: 19. jul 2007, 19:35
Geografisk sted: Nordjylland

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf Jimmyfj » 4. sep 2015, 10:29

Jeg autosaver brugernavn og adgangekode i Firefox og skal således bare klikke på login, (nogle gange vinger jeg "Husk mig" af (uden noget resultat næste gang jeg besøger sitet - Til at leve med)).
"OM 100 ÅR ER ALTING GLEMT !"


Ubuntu - Dev-ed.
Linux User # 448500

AJenbo
Admin
Indlæg: 20573
Tilmeldt: 15. nov 2009, 15:04
IRC nickname: AJenbo
Geografisk sted: Vanløse, København

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf AJenbo » 4. sep 2015, 11:56

Det lyder som om du faktisk rammer spam filteret, det tror jeg ikke vi kan komme længere med uden at kende ip på et tidspunkt for den afviser.

Mht til husk logind så forventer vi at det løses når vi er klar med phpbb 3.1

Brugeravatar
Christian.Arvai
Admin
Indlæg: 10704
Tilmeldt: 26. apr 2008, 19:27
IRC nickname: Christian_Arvai
Geografisk sted: Holeby - Lolland

Re: fejl når jeg klikker ind på afdelinger..

Indlægaf Christian.Arvai » 4. sep 2015, 12:40

Jeg kan prøve at justere på filteret. Det kræver så lige at jeg kan se årsagen i loggen først. Så næste gang at fejlen opstår, må du gerne notere tidspunkt og din IP. Så kan jeg se præcist hvilken årsag der smider dig af.
Med venlig hilsen Christian

"We can only see a short distance ahead, but we can see plenty there that needs to be done." -- Alan Turing

Tilbage til "Ubuntu Danmark"

Hvem er online

Brugere der læser dette forum: [Crawler] og 0 gæster